6

When I am trying to show label of these roads parallel almost all roads are showing, but in curved type visibility of labels are getting reduced. How I can show all roads names curved to road?

Using QGIS v2.18.20 in Windows.

enter image description here

  • 1
    try change maximum angle between curved characters in "Placement" field or check 'show all labels for this layer' in "Rendering" – Jane Sep 5 '18 at 7:43
  • Tried with all options, Still there is no change. – Rashmita Sep 5 '18 at 8:20
  • try: Label polygons using curved labels along the perimeter. – Swarley Sep 5 '18 at 15:11
  • These are all lines, Can I apply perimeter concept here as well? If yes how? – Rashmita Sep 6 '18 at 8:57
1

May be you could try this two options:

  1. In case your lines come from several files, you can set priority to highest in all of them (label properties). enter image description here

  2. In case, all your labels come from one layer, you can show all labels, even if they overlap because of the size or whatever. enter image description here

0

Sorry this is probably too late to help you but in case it helps others. I was having this same issue and have just resolved it.

It turned out my polylines were multipart features an QGIS was only labeling one part.

In Label -> Rendering options check to boxes marked "Label every part of multipart features" and "Merge connected lines to avoid duplicates"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.