3

I was clipping vector layers yesterday with no problems, and now all of a sudden it doesn't want to work and keeps giving me an error stating:

Feature (2) has invalid geometry. Please fix the geometry or change the Processing setting to the "Ignore invalid input features" option. Execution failed after 0.05 seconds

I even created a new project and tried to re-clip a vector layer that I did yesterday, and now it doesn't work. Also, the error message says to change the Processing setting to the "Ignore invalid input features", but I can't see any options in the clipping window.

Setting up the clip:

enter image description here

Fails:

enter image description here

  • @JohnGIS, can you please show how do your shapefiles look like? – Taras Sep 7 '18 at 9:17
4

For the Processing setting "Ignore invalid input features" you have to look in the general option in the processing tab enter image description here

For the different CRS my understanding is that QGIS 3 take care of reprojection during processing but you may try to re-project yourself to run the clip tool with two SHP in the same CRS....

  • Thanks for showing me where this option is. The algorithm now runs but the outcome layer can not be seen. This still happens if both layers are in the same CRS. – JohnGIS Sep 7 '18 at 10:24
  • 1
    try the "Check validity" tool in processing to assert that you don't have any geometry problem – J.R Sep 7 '18 at 11:38
1

The layers are in different coordinate systems. They might not be intersecting at all. You should use the same CRS

  • Sorry, this was a bad example. The shapefiles I am currently trying clip are in the same CRS. Weirdly though, this example I have shown with the different CRS shapefiles, clipped with no issues. – JohnGIS Sep 7 '18 at 10:11
  • That's not a problem in QGIS 3 - they are automatically reprojected on the fly – ndawson Sep 7 '18 at 19:12
0

Under closer inspection of the vector layer, I noticed there were a few occasions where lines were crossing each other. After manually removing the unnecessary vertices, I can now clip with no more issues

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.