1

I would like to export my map as a GeoTIFF in QGIS. My workflow is as follows: Project - Import/export - export map to image…

I have two questions about this: instead of saving the image as a GeoTIFF, QGIS saves it as a normal TIFF file and a world-file. How can I export it as a single GeoTIFF?

Also, when I re-import the image into QGIS, it returns the error message that the coordinate system is not defined. How can I export the image correctly with the coordinate system, which I had put for the map?

closed as too broad by csk, Vince, xunilk, Aaron Sep 11 '18 at 4:44

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Possible duplicate of How to convert a .tif with .tfw to a GeoTiff? – csk Sep 10 '18 at 20:32
  • I fear this is a missing feature in Export to map image. You can fix it by post-processing with gdal gdal_translate -of GTiff -a_srs epsg:xxxx input.tif output_geo.tifwhere xxxx in epsg:xxxx is the projection code that you probably know. Or use gdal_edit.py and attach the coordinate system in place without creating a copy of the image. – user30184 Sep 10 '18 at 20:40
  • Hi user30184, thanks a lot for the suggestion. I tried it and indeed managed to get a geotiff. However, the problem about QGIS complaining that the coordinate system is not defined persists… Any idea what could have gone wrong? – ioeidos Sep 10 '18 at 21:17
  • As a fairly new user, please take the Tour, which emphasizes the importance of asking one question per Question. – Vince Sep 10 '18 at 22:03
0

While exporting you have to tick the box to generate the georreferencing file (as you can see in the picture). This will generate a tiff file and a .tfw file. The TFW is the file which contains the geographic parameters to open the image correctly in QGIS (try opening the TFW with notepad and you'll see what I mean).

enter image description here

  • Hi Guillermo, thanks for your response. It does not quite answer my question though. I want to have a single geotiff file in the end and also am having problems with the coordinate system (see above). I don't quite see how your answer relates to either of these problems. – ioeidos Sep 10 '18 at 19:37
  • You are welcome! I've tried deleting the auxiliary files, keeping only the tiff, and QGIS loaded it properly placed, without any georreferencing issues. Also you can re-export it with QGIS (no need of using "proccesing"). It worked for me on QGIS 3.2 – guillermo_dangelo Sep 12 '18 at 14:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.