3

Last week I try unsuccesfully to install the plugin to open ecw files in QGIS 3.2.on Ubuntu 18.4. Since then GDAL algorithms are not working for rasters. I have the exact same error for all of them:

Proces algorithm: Algoritmo 'Orientación' comenzando… Input parameters: { 'BAND' : 1, 'COMPUTE_EDGES' : False, 'INPUT' : '/home/basi/Escritorio/GEA Forestal/Proyectos/Biomasa/Mapas/MDT/MDT Gu.tiff', 'OPTIONS' : '', 'OUTPUT' : '/tmp/processing_32b112e632e44e699178c61428af21c2/bd7b41926c554ce5811f8c5bc6954822/OUTPUT.tif', 'TRIG_ANGLE' : True, 'ZERO_FLAT' : True, 'ZEVENBERGEN' : False } GDAL command: gdaldem aspect "/home/basi/Escritorio/GEA Forestal/Proyectos/Biomasa/Mapas/MDT/MDT Gu.tiff" /tmp/processing_32b112e632e44e699178c61428af21c2/bd7b41926c554ce5811f8c5bc6954822/OUTPUT.tif -of GTiff -b 1 -trigonometric -zero_for_flat GDAL command output: gdaldem: error while loading shared libraries: libNCSEcw.so.5.3.0: cannot open shared object file: No such file or directory Execution completed in 0.05 seconds Results: {'OUTPUT': } Charging result layers Next layers were not generated correctly.

  • /tmp/processing_32b112e632e44e699178c61428af21c2/bd7b41926c554ce5811f8c5bc6954822/OUTPUT.tif

I tried to reinstall gdal and qgis, but same problem persists. Any idea?

  • 1
    As I see, you are under linux. You need to install ERDAS ECW/JP2 SDK manually. Do you did it? – Dmitry Baryshnikov Sep 14 '18 at 14:37
  • @DmitryBaryshnikov, the question is rather about how to delete all tracks of previous unsuccessful installation of the ECW plugis. The system seems now to remember that it should load that plugin even user wants just use QGIS without it. – user30184 Sep 16 '18 at 12:25
  • @user30184 it seems to me the problem is about your libgdal installation, not ECW SDK or any plugin. You get GDAL with compiled ECW driver, and this driver try to load libNCSEcw.so.5.3.0 which is not present in your OS. You can disable ECW driver using GDAL_SKIP config option. But install clean libgdal, gdal-bin and gdal-data is advisable. – Dmitry Baryshnikov Sep 16 '18 at 14:48
  • It is not my installation but based on what the OP wrote it used to work until the trial to install the plugin. – user30184 Sep 16 '18 at 14:53
  • I tried to install ERDAS ECW/JP2 SDK unsuccesfully. And the problem is not with it, it is about GDAL Algorithms not working I gues, because there are some libraries or something that makes them not work. I don know how to use GDAL_SKIP. There is any instructions somewhere apart of the link that you already share?? – B RG Sep 17 '18 at 7:02
1

No. But I remember having issues with reinstallations of QGIS due plugin issues. Make sure you really purge all the related files before installing it again. You might have a .temp folder or a user specific .config file that is still wrongly configured. If you still have issues try with a LTR. What OS are you using?

  • I am using Ubuntu 18.4. I tried to clean and purge everything, but it didn't work. Any instructions to clean everything before reinstalling? – B RG Sep 17 '18 at 7:05
  • A complete uninstall of QGIS might not solve the gdal issue. Have you tried $ sudo apt-get remove --purge gdal-bin ? Once QGIS and GDAL is working as it should, have a look at this: link It might be the solution to your initial issue. – Roberto Zeeland Sep 17 '18 at 7:23
  • I have unistall it with the command line and install it again using $sudo apt-get install qgis python-qgis qgis-plugin-grass Same problem persists,no solution for the moment. – B RG Sep 17 '18 at 7:55
  • Now I am just throwing things into the question answer brainstorm. What about $sudo apt-get autoremove once you have uninstalled everything ? This will delete the related dependencies which are not used once qgis/gdal is uninstalled and might be causing trouble. I would then proceed by cleaning hidden folders in your user folder .local/share/QGIS/QGIS3/profiles/default (To see hidden folders press Ctrl+h). – Roberto Zeeland Sep 17 '18 at 8:12
  • Thanks for your help Roberto but still not working. I tried to delete not only the default folder, but all ecw and libNCSEcw files and folders, and still no solution... – B RG Sep 17 '18 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.