1

I'm using Mapnik to show a map with hillshading. It works well when displaying it up to my tiff's native resolution and a little bit above, for instance at zoom 13 (dataset is SRTM30):

enter image description here

But then if I continue to zoom in, the hillshade isn't smooth anymore and looks like vector polygons, like on this screenshot at zoom 16:

enter image description here

I'm currently using bicubic scaling but I tried every single other option without seeing much improvement. Upscaling my raw image at the same resolution with Photoshop works perfectly, with smooth fading.

Is there a way to improve this result? I tried to add agg-stack-blur without success.

0

Problem was mod_tile's output format, which is 8 bits PNG. Recompiling mod_tile to make it generate 32 bits PNGS solves the problem (but multiplies the tiles size by 3).

More details here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.