0

I have a map with three layers:


  1. "Dorset Points", point shapefile
  2. "Counties...", polygon shapefile
  3. "Kilwood Park", raster

I'm trying to project all three layers onto WGS 84. The project CRS is set as WGS 84 and I've manually set each layer to project to WGS 84. I've enabled "on the fly projection" as well. However, layers 2 and 3 align properly while layer 1 lies out in the ocean. Also, when scrolling with my mouse, my coordinates are displayed as what looks to be northings and eastings instead of decimal degrees as I would expect with WGS 84. When I zoom to layer 1, my scrolling mouse shows decimal degrees. I know layer 2 has decimal degrees as you can see in the attribute table. I've tried using the field calculator to produce x and y coordinates using $x and $y but my output was null.

Please let me know of anything else to try! I know there are many resources on projecting but so far I have tried every fix I could find.

enter image description here

  • 5
    "I've manually set each layer to project to WGS 84" worries me. Normally spatial data knows what projection it is and what its coordinates are, and you don't have to set each layer "to project to WGS84". You tell QGIS the map is in WG84 and it transforms the shapefiles from their coordinates to WGS84. If you have a shapefile in UK National Grid coordinates but set its projection to WGS84 then you'll get a shape with lat-long coordinates in the thousands as you see here. – Spacedman Sep 17 '18 at 21:16
  • 1
    This is actually one our most frequently asked questions. The problem isn't your use of the application, but of the data itself. While all three might claim to be WGS84 decimal degrees, at least one of the layers isn't. – Vince Sep 18 '18 at 3:02
  • Thanks for the help guys. I know one of my data sources might not be originally in WGS 84 but I thought it would be possible to re-project data from the British National Grid – amarie279 Sep 20 '18 at 15:29
2

It seems as though you may have used the "Set Layer CRS" option from right-clicking on the layer name. This method is used to redefine a layer's CRS, essentially overriding the CRS that is 'built-in' to the original shapefile.

If you only need to display the data in WGS84, then you have headed in the right direction:

  1. Turn on "On-the-fly projection"
  2. Set the desired CRS for the project by using the button in the bottom-right corner and setting it to EPSG:4326 (WGS84)
  3. Add your shapefiles into the map

QGIS reads the CRS from their respective .prj files and projects them into WGS84 for you behind the scenes - this is the "on-the-fly" part.

On rare occasions something in the .prj file might not read correctly or is erroneous and you will have to define it manually, which can require going back to the source, referring to the metadata, inspecting the coordinate values, and other sleuthing.

A good place to start is to right-click the layer --> Zoom To Layer. Inspect the extent of the coordinates the features cover. In WGS84, one should expect values to range less than 360deg in the X and less than 180deg in the Y. If values are orders of magnitude outside this range, then you are likely dealing with data in a projected CRS with linear units (meters, ft, etc).

  • Hi Crystalline, thanks for your help. My problem was that, when asked by QGIS to define the source CRS of the layer, I was selecting WGS84, the desired CRS. – amarie279 Sep 20 '18 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.