0

I am curently searching for some Python 3.x bindings for PCL on Ubuntu (16.04).

The ones I found are:

  • pclpy: pip cannot find it.

  • python-pcl: I have tried to install it but I always end up on errors with missing files or unmet dependencies or version issues... What is strange is that it is the only one listed on the PCL main page: http://pointclouds.org/news/tags/python !

  • PyPCL: I can install it with pip but it's not documented at all.

Which one is the most used, the most efficient and up-to-date to process point clouds from Python?
Did I miss some other package(s)?

Edit:

to answer properly the 1st comment below:

I tried to install python-pcl:

  • 1st error along with many many warnings about deprecated functions:

    pcl/_pcl_180.cpp: In function ‘int __pyx_pf_3pcl_4_pcl_18ConditionalRemoval___cinit__(__pyx_obj_3pcl_4_pcl_ConditionalRemoval*, __pyx_obj_3pcl_4_pcl_ConditionAnd*)’: pcl/_pcl_180.cpp:48508:153: error: no matching function for call to ‘pcl::ConditionalRemoval<pcl::PointXYZ>::ConditionalRemoval(__pyx_t_3pcl_15pcl_filters_180_ConditionBasePtr_t, NULL)’ __pyx_v_self->me = new __pyx_t_3pcl_15pcl_filters_180_ConditionalRemoval_t(((__pyx_t_3pcl_15pcl_filters_180_ConditionBasePtr_t)__pyx_v_cond->me), NULL);

My PCL version is 1.8.1.

  • For python-pcl - did you follow the install instructions here? If you use conda, a prebuilt version is also available from the conda-forge channel. – user2856 Sep 18 '18 at 23:46
  • It doesn't work. I updated the main post about that. I use pip, not conda. – s.k Sep 19 '18 at 6:11
  • pclpy is supported for window only at this point, per to the documentation – Zachi Shtain Jul 9 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.