0

I am trying to install MOLUSCE plugin on ubuntu but every time i try i get an error message saying:

The plugin is broken. Python said:

Error Reading metadata: general

There is a screenshot so, does anyone have a solution?

I have used this plugin on Windows earlier but now i am working with linux so i would like to now if there is some solution for using this plugin on ubuntu?

enter image description here

1
  • You do not say what version you are using, but I tried in QGIS 3.12 and 3.01 and both are showing: > This plugin is broken > >Error reading metadata: general Apr 30 '20 at 4:04
1

I tried opening the latest in QGIS 2.18.13 on Mac and it seemed ok. It's having problems reading the metadata.txt file which is what QGIS plugins use to describe themselves.

This is probably caused by either

  • a line getting corrupted in the metadata.txt file. Try uninstalling this plugin and reinstalling it, and restarting QGIS.
  • attempting to open a QGIS2 plugin manually into QGIS3 (this isn't listed as a QGIS3 plugin)
  • a platform specific glitch in Linux

You could try installing an earlier version manually from here, go the versions tab. Try the second most recent version (3.0.11 at the time of writing).

The most recent version had a change in that part of the file so it's possible that your version of QGIS for Linux doesn't like the latest version (maybe the multiple-line plugin description?)

It's probably a good idea to raise a bug in the issue tracker but you'd need to specify which version of QGIS (and plugin) is affected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.