5

How do I change the data source encoding of the GetFeatureInfo Request of a WMS-Layer in QGIS 2.18.x/3.x? I can't find any setting to handle the encoding. I need UTF-8 encoding for special characters like 'ä;ö;ü;ß' of a german WMS-Service.

As you can see in the screenshot below, the "Identify Results" shows a wrong charset.

Screenshot WMS identify result

  • is this for the name of the layer? or something else? – Ian Turton Sep 21 '18 at 8:32
  • 2
    WMS has no attributes, what do you want to change the encode for? – Alexandre Neto Sep 21 '18 at 8:33
  • WMS contain images, therefore you don't need to fiddle with any encoding. – Erik Sep 21 '18 at 8:49
  • 1
    @AlexandreNeto what do you mean "WMS as no attributes"? Assuming you mean "WMS has no attributes", then that is incorrect, the WMS GetFeatureInfo request returns layer attributes. – user2856 Sep 21 '18 at 9:06
  • @MAP, can you try this ISO 8859-1? It always adjusts my Umlaute and Eszett. – Taras Sep 21 '18 at 9:11
1

I added a screenshot. I'm not serving the WMS. The identify results are not interpreted in the correct charset like UTF-8 or ISO 8859-1.

The results are returned in text/plain which defaults to us-ascii so I'm not sure it's correct to say the results are not interpreted in the correct charset.

Rather than use text/plain you can retrieve using using text/html and application/vnd.ogc.gml which are likely to have other encodings.

There is no way as far as I know to request a different encoding through a GetFeatureInfo request, so your options are limited.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.