2

Update:

My final solution was to re-download the data sets and all my alignment issues were solved.

Background:

I am working on a personal project overlaying the location of churches/parishes on various counties in New Jersey. The parishes are contained in a .geojson file and the state counties come from a shapefile provided by the state.

Problem:

When both layers are loaded the parish layer is way up to the left of the counties and both have different CRSs. The parish is EPSG:4326 - WGS 84 while the counties are the same as the project crs EPSG:3857 - WGS 84 / Pseudo Mercator. When I change the crs of the parish layer to the projects there are alignment issues and scale issues. The parishes are much closer (but still not over the counties) and to the bottom left. Further the scaling goes wrong and all the data points are much to close to each other.

How do I resolve this alignment issue?

The final result is I will be making a map to print out, which I can do now my manual exporting the layers at a fixed scale. Then I can manually align the two exports in my image editing software. I would prefer to figure out this issue mainly to learn more about these things.

Key Information and Links:

Parish Layer CRS: EPSG:4326 - WGS 84
Project CRS: EPSG:3857 - WGS 84 / Pseudo Mercator

Base data source comes from State of New Jersey - GIS Open Data State Counties.
Link Here: https://njogis-newjersey.opendata.arcgis.com/datasets/5f45e1ece6e14ef5866974a7b57d3b95_1/geoservice?geometry=-78.816%2C39.583%2C-70.472%2C41.049

I made the parish data source using geojson.io. You can view the data source one either:
GitHub: https://github.com/pulsence/diocese-of-metuchen-parish-map or
GeoJson: http://geojson.io/#id=github:pulsence/diocese-of-metuchen-parish-map/blob/master/parish%20locations.geojson&map=10/40.6289/-74.7065

I am using for this project QGIS 3.0.3-Girona.

closed as off-topic by AndreJ, Vince, nmtoken, Mark Ireland, csk Sep 25 '18 at 16:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – AndreJ, Vince, nmtoken, Mark Ireland, csk
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    The counties are not EPSG:3857, but EPSG:4326 as well (or NAD83). Both fit to an OSM background in QGIS 2.18. There might have been a bug in QGIS 3.0.3, so I suggest to update to QGIS 3.2.3. – AndreJ Sep 24 '18 at 9:29
  • Ok, so I went and played around with the CRSs after updating to the latest QGIS 3.2.3. I made all the layers and the project EPSG:3857 and EPSG:4326 and different combinations. The consistent issue is that the counties layer and parish layer are not lining up. I have both layers visible at the same time, however I would have expected the two layers to actually over lap. Even more interesting, I added an OSM background and with everything is EPSG:4326 the counties are over Nigeria and parishes are in the Atlantic off the coast of Nigeria. – Timothy Sep 24 '18 at 13:10
  • I think your basic error is to use Set Layer CRS assuming it would reproject your data.Unless you requested the county layer in EPSG:3857, it is EPSG:4326 by default. Let both layers in their native projection, and set the project CRS to 3857, then add an OSM basemap. – AndreJ Sep 24 '18 at 13:32
  • I get that. The only way I get the parish layer to line up on the OSM is by the two CRSs (project and layer) being different. With the counties at the native CRS they don't appear on the OSM for me, but when I Zoom To Layer for the counties I go to the middle of the OSM map, Nigeria. Sorry if that's not the most clear. – Timothy Sep 24 '18 at 13:56
  • Can you post the extent of the counties layer, as reported in the layers properties, metadata tab? – AndreJ Sep 24 '18 at 14:12
2

The solution was to re-download the data sets and then the alignment issues were solved. I do not know what caused the issue in the first place.

Not the answer you're looking for? Browse other questions tagged or ask your own question.