I am working with QGIS 2.18 where I do have several shapefiles in EPSG 4326 and encoded in ISO 8859-1, see image below.


I can check their geometry state for instance with Geometry Validator or Check Geometries plugins. As the result, I do not have any vital issues, and it basically means that the geometry itself is not missing. See the output below.


But when I open both of them in MapInfo Pro 16.0 I can't see any of them. I did it through the following command (see the image below)

Home > Open > Relation


Then MapInfo asks me to save my shapefiles with .tab extension. And I proceed with it.

And after I can not see my shapefiles in MapInfo. Check the following image.



I tried to Save As... MapInfo TAB which did not solve the issue.

I deployed ogr2ogr from the GDAL/OGR Processing Toolbox, where I used [OGR] Conversion > Convert format. However, the output still does not want to show up in MapInfo.

Moreover, I changed the encoding between System, UTF-8 and ISO 8859-1, nothing helps.

I have tried to Save As... GML file, also does not help.

In MapInfo

I tried "Universal Translator". Nevertheless, I do not have an option to chose .shp format from the "FME Reader Galarie" list, but there are some other options, for instance .gml, .kml, .gdb, .mdb etc.

I have also tried with MapInfo Professional 12.5, and MapInfo Pro 15 - nothing.

So, my Question is: What could be actually the problem? Geometry? Coordinate System? Original data (which was created from .dxf)? Wrong conversion from QGIS into MapInfo? Corrupt data? Wrong execution of the data input in MapInfo?

I have tried several similar topics but they do not transparently respond to my issue.

  • Are there any rows when you browse the tables (F2)? Did you try "View Entire Layer"?
    – CL.
    Commented Sep 24, 2018 at 12:26
  • Yes, I do have rows in the attribute table, but I do not see them in the workspace
    – Taras
    Commented Sep 24, 2018 at 12:43
  • 1
    Please provide a small sample of the original SHP. The issue is unlikely to be QGIS or MapInfo, but the structure or form of the data themselves.
    – Ralph Tee
    Commented Sep 26, 2018 at 11:59
  • 1
    Create a simple shapefile, making sure the topology is correct, like for example only one polygon with a few attributes. Export this file from QGIS to MapInfo and see what happens and also try all other conversion options you mentioned. This way you know that your converters are working and you can eliminate one unknown in your problem. Also, use the default encoding, and change one thing at a time to see where the process fails.
    – Techie_Gus
    Commented Sep 26, 2018 at 14:41
  • 1
    @Taras. You actually have one Duek_Flachen.SHP and one Duek_Flachen.SHP.XML. Same as all other SHPs and XMLs. Check your Windows Explorer setting (ie Menu->View->Options->View->Files and Folders->Hide extensions for known file type). And, (2) as for your other questions - put them as separate, and I'm sure many good folks here (me included) would be more than happy to answer them.
    – Ralph Tee
    Commented Sep 28, 2018 at 15:56

2 Answers 2


Conclusion: Always check the data input.

I have recently doublechecked the data state and structure as was suggested by @Ralph Tee and realized that several of my shapefiles are missing the projection files .prj, see image below.

It was my fault that I asked my initial question based on the already processed data, without examining the raw input.


Luckily one of the origin shapefiles included the .prj file, where it says


So, it is basically EPSG:25833 which could be easily chosen for the rest of shapefiles. Afterwards, the reprojection process is reasonable.


If you save your layer in another shapefile with selection of geometry type : 'Polygon'?

Or if you save your layer in MapInfo MIF/MID (not MapInfo TAB...) to import data with MapInfo?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.