I have been having problems with the Convert Time Field tool. I am able to convert the date with no problem but the time is being deleted. One time it worked OK but then when I selected a subset of records and did an Export Data on the Shape file, the time part to the date field was deleted during the export. The input date string (as string) looks like this yyyy-MM-dd'T'HH:mm:ss'Z' I have tried both preset and custom string specifications. The log claims that the process was successful, but the result is not what I need.

1 Answer 1


Shapefiles can't store datetime fields like this in their *.dbf attribute table. You may have better luck exporting to and/or storing your data in a Geodatabase which will support a more robust datetime. Check this thread for more information: http://forums.esri.com/Thread.asp?t=106423&c=93&f=1149

Presumably your output looks something like yyyyMMdd (8 bytes). If that is the case, then the assertion I made above and that is made in the linked thread is true. If the field is being written with null values the issue may be a bit more deep-seeded and require further delving.

Info on how a Date field is stored in a dBase *.dbf: http://www.dbase.com/knowledgebase/int/db7_file_fmt.htm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.