0

I am using QGIS 2.18.15. I tried clipping a raster

enter image description here

The mask layer is a shapefile. And it comes out as "ERROR 1: Cutline feature without a geometry"

I checked the point data that I interpolated and it's in the proper coordinate referencing system.

The intention is to clip the raster to the map at the back.

enter image description here

1

CRS != geometry - seems like your shapefile has a faulty geometry. Go to vector -> geometry tools -> check validity and repair any faults which show up.

Also try using dissolve in order to remove overlaps in the geometry.

  • I tried it, and all points came out as valid... – cmjv Sep 24 '18 at 15:10
  • Wait... you're trying to clip a raster to points? Or do you mean it only turned out valid vertices? – Erik Sep 24 '18 at 15:11
  • im trying to clip a raster of points to a shapefile layer map... i tried doing it before and it worked but now the error comes out – cmjv Sep 24 '18 at 15:12
  • 1
    Did you use the same shapefile the last time? Because it seems to have multiple parts, which could be a source of error. Have you tried using "dissolve" on your shapefile/mask? – Erik Sep 24 '18 at 15:21
  • 2
    Dissolve is a tool that takes multiple features and merges them into one. Use it to merge your polygons into a single polygon. – csk Sep 25 '18 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.