1

I'm trying to install QGIS through conda $conda install -c conda-forge qgis but got the following error

Solving environment: failed

UnsatisfiableError: The following specifications were found to be in conflict:
  - anaconda==5.2.0=py36_3 -> mkl-service==1.1.2=py36h17a0993_4
  - anaconda==5.2.0=py36_3 -> numexpr==2.6.5=py36h7bf3b9c_0
  - anaconda==5.2.0=py36_3 -> scikit-learn==0.19.1=py36h7aa7ec6_0
  - qgis
Use "conda info <package>" to see the dependencies for each package.

I've tried update one of those by $conda install -c conda-forge numexpr however I am still getting the same error afterwards. Any hints?

  • Just tried a minimal conda create -c conda-forge -n qgisenv python=3.4 qgis spyder pyodbc matplotlib scipy numpy but I"ve got a nasty UnsatisfiableError: The following specifications were found to be in conflict: - matplotlib - qgis Can't they work together for real? – Marcelo Silva Sep 26 '18 at 20:31
  • Only QGIS 2.18 is available for Linux via conda-forge and it requires Python 2.7. You can't use Python 3. – user2856 Sep 26 '18 at 20:42
1

Only QGIS 2.18 is available for Linux via conda-forge and it requires Python 2.7.

Try:

conda create -c conda-forge -n qgisenv qgis

You won't be able to install matplotlib though. I'm not sure where the fault is.

If you restrict packages to the conda-forge channel (conda create/install -c conda-forge --override-channels etc...) then QGIS 2 conflicts with conda-forge matplotlib.

If you allow packages from the default channels (conda create/install -c conda-forge etc...) then matplotlib from defaults requires Qt 5.9 but QGIS requires Qt 5.6. I can't find a way around it at the moment

  • Hi @Luke, I've tried that too... $ conda create -c conda-forge -n qgisenv python=2.7 qgis spyder pyodbc matplotlib scipy numpy Solving environment: failed UnsatisfiableError: The following specifications were found to be in conflict: - matplotlib - qgis Since I'm still learning both python and qgis, I think I'll go without mathplotlib... that I was including as a way to plot some data that I'll be querying from an sqlserver (already being fed by a sensors network). – Marcelo Silva Sep 26 '18 at 21:26
  • conda create -c conda-forge -n qgisenv01 python=2.7 qgis spyder pyodbc scipy numpy didn't work either... now spyder cant be launched... anaconda3/envs/qgisenv01/lib/python2.7/site-packages/qtpy/__init__.py:211: RuntimeWarning: Selected binding "pyqt5" could not be found, using "pyqt" – Marcelo Silva Sep 26 '18 at 21:58
  • I think you'll have to raise an issue with conda-forge. Not sure where the fault is. If you restrict packages to the conda-forge channel (conda create/install -c conda-forge --override-channels etc...) then QGIS 2 conflicts with conda-forge matplotlib. If you allow packages from the default channels (conda create/install -c conda-forge etc...) then matplotlib from defaults requires Qt 5.9 but QGIS requires Qt 5.6. I can't find a way around it at the moment. – user2856 Sep 26 '18 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.