0

I have a pointcloud in postgis, imported using pdal pipeline and chipper to 600 points per patch. I have the pointcloud (only 5000 points) displayed in QGIS. How do I get QGIS to render in in 3D in the 3D viewer, for some reason it is ignoring the z-dimension. It is displayed using the database manager and the following query.

SELECT PC_EXPLODE(pa)::geometry
                 as geom
                 from pcpatches

The screen shot shows the 3D viewer on the right, it should be a deep trench.

Screenshot

1

I am fairly certain that the 3D viewer is only capable of rendering 3D vector features as being draped onto a surface. I was also a bit disappointed by this but sometimes that is the nature of open source, you really do get what you pay for, and if you don't pay, well sometimes you don't get what you want.

I really hope that 3D vector rendering will become part of QGIS soon.

  • I'm now looking into scipy options, I'm sure QGIS will go fully 3D in time, it is still ahead of ESRI. – Spatial Digger Oct 8 '18 at 7:31
0

QGIS should use the Z value of your points. Did you set the right option for the 3D renderer (I mean the option in the layer styling panel, you have to set it for each layer you intend to visualise in 3D).

Make sure that you tick the "Enable 3D renderer" Check box and Choose the "Altitude Clamping" as "Absolute"

enter image description here

If the 3D renderer didn't work for you you could also try the Qgis2threejs plugins that usually give good result for 3D visualitation (in fact I find that the 3D renderer causes a lot more of crash (save often if you use it) than Qgis2threejs plugins)

  • yes, still as flat as a pancake. – Spatial Digger Oct 8 '18 at 12:10
  • I test it and I get 3D (my 3D points are clearly above their ground position), are you sure that the way you get your point preserve Z value ? – J.R Oct 8 '18 at 12:24
  • I also get a real 3D elevated point viewing my exploded pcpatch. You might need to zoom and flip map to get underneath points for best 3D viewing. – Jakob Jan 22 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.