2

I am trying to calculate the area of several polygons on ArcMap (10.3.1). The polygons are all on the same layer.

I am using NAD 1983 UTM Zone 16 as my projected coordinate system. I have tried to calculate the area (m^2) using "calculate geometry..." (my field is set to double with precision 15 and scale 2). All the areas come back as 0. When I click on individual boxes, I see that the values are not actually 0, but something like 3E-8 meters^2 (which is definitely not correct).

Any suggestions on what may be causing this?

  • 1
    Welcome to GISSE. It could be a issue with how the polygons were created. Try running 'Repair Geometry' in arc. *If that doesn't work, try converting the polygons to lines and then back to polygons using polygon to line then feature to polygon (*this may not work if the polygons overlap - see the tool help). – jbalk Sep 27 '18 at 20:05
  • Use the measure tool to estimate the area of one of the polygons. Does it give you a different result than the "calculate geometry" method? – csk Sep 27 '18 at 20:18
  • 1
    An invalid geometry like a "bowtie" will report zero area because the two triangle halves offset each other. You should validate (and/or repair) your geometry source. – Vince Sep 27 '18 at 21:36
  • Thank you for the help! The measure tool gave the same result, area of 0. It appears it's definitely something with invalid geometry. I ran repair geometry and that removes all the polygons (says that there are self-intersecting lines & geometry is null). However, if I run a repair geometry while my layer and shapefile have a geographic coordinate system (as opposed to projected), the null geometry and removal of the polygons does not happen. The shapefile is repaired, but the invalid geometry returns when I switch it all back to a projected coordinate system. Any further suggestions? – Monica Sep 27 '18 at 23:48
1

Figured out the problem! I was doing my repairs & switching between systems in the wrong order.

Before attempting to find the area, I needed to repair the geometry of my polygons. This had to be done in GCS North American 1983, the original coordinate system in which I collected my data in (I think). The repair worked fine, creating a new layer for me. Then I was able to use PROJECT from the toolbox to get my polygons in a projected coordinate system. After this step, both "calculate geometry" and the measure tool worked! The calculated area is reasonable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.