2

For some reason, the Raster Calculator isn't honoring any Raster Storage environments that I have set. Mainly, compression and pyramids. I am processing a large raster dataset through raster calculator (there are multiple products/ iterations of calculations), so I am having storage issues. From what I have read online, these settings should not be ignored by the Raster Calculator. I am working off ArcGIS 10.4, but do have access to ArcGIS Pro if needed.

Does anyone know why this is happening and/or how I can resolve this issue?

http://desktop.arcgis.com/en/arcmap/10.4/tools/environments/an-overview-of-raster-storage-settings.htm

I am working with a water surface elevation raster. It is in TIF format. I have attempted to set it with a compression of both LZW and LZ77. The settings have been set both globally and locally on the tool. The Build Pyramids box is checked in Raster Storage. Here is a snapshot of the settings I am using:

Storage Settings Being Used

Output Characteristics: The rasters are not corrupted, which is good news. Here are the properties of the new rasters after using the global settings shown above:

Output Raster Specs

  • Please Edit the question to provide more details on the input and output data formats, the options you've specified, and th actual characteristics of the resulting raster. – Vince Sep 28 '18 at 12:52
  • @BERA I am not using a model, just the Raster Calculator. The settings have been set globally (in the MXD). – MoreMeowbell Sep 28 '18 at 13:53
  • 1
    It looks like you are using a floating point raster and compression is not supported for that. Can you convert it and use it as an integer raster instead to take advantage of compression? – johns Sep 28 '18 at 14:15
  • Unfortunately, it must remain floating point for accuracy purposes. Is it because it is floating point that it won't compress? I couldn't find any documentation on that. – MoreMeowbell Sep 28 '18 at 14:33
  • 3
    From the Raster Calculator Help: "For the Compression environments, only the type of Compression is supported. This environment will only apply when the output would be of integer type. Compression is not supported on floating point rasters, so this environment will only apply when the output would be of integer type." But you can preserve your accuracy with a bit of a trick enumerated here: support.esri.com/en/technical-article/000012554 in which you multiply your values by 10,100. etc whatever places needed, then convert to an integer, and later divide by the same value to correct. – johns Sep 28 '18 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.