1

I downloaded OSM data for Austria from Geofabrik and converted them with ogr2ogr into a SpatiaLite database so that I could use some Google Maps style sheets I found.

Until here, everything worked very well.

Then I wanted to add a shapefile with some points I tracked in nature as well as a orthophotografic I bought at an official government store.

That works also, but the OSM data on the one hand and everything else on the other do not match. My own data is about 50 meters farther east than it should be to match the correct point on the OSM data.

I looked for on-the-fly transformation, but as I read this feature isn't optional any more since version 3.

I use QGIS 3.0.1 and as CRS WGS 84 (EPSG 4326)

enter image description here

enter image description here

enter image description here

enter image description here

  • 1
    What coordinate reference has the other data you got? OSM is most likely WGS84. But you need to have the correct settings for both datasets. It might be that you are missing datum transformation for "the_other_data_crs" -> "WGS84". This often leads to errors in the range of your 50m. – Matte Oct 1 '18 at 10:14
  • 1
    I guess it should be also wgs84 - how can i check? And i also thougt that qgis will transform everything to my prederrd crs since 3.0? – darius Oct 1 '18 at 10:19
  • Official data usually does not use WGS84 but a local reference. QGIS/OGR will transform when it recognizes the other crs correct. You need to check that against the documentation of the datasets you bought and what you used when you tracked your points (see Answer from til_b). There is also another, unlikely, possibility that there is no exact transformation available for your pair of CRS. – Matte Oct 1 '18 at 11:57
1
  • Check the CRS of all datasets. Doubleclick the layer, choose "Information" and look at the values there.
  • Government data (at least here in northern germany) almost never uses WGS84, but UTM, most commonly UTM32, EPSG:4647 or EPSG:25832.
  • Did you specify the output CRS for your Spatialite DB? Maybe that got lost in the transformation, please provide the full ogr2ogr command line you used.
  • 1
    i had a look now. the osm layers tell me in the information tab, that the crs is wgs84, the layer that contains my personal tracked points is also on wgs 84, but does not match the osm drawings and the geoimage tells me that its a in a user csr... (USER:100000 - * Erzeugtes KBS (+proj=tmerc +lat_0=0 +lon_0=16.33333333333333 +k=1 +x_0=0 +y_0=-5000000 +ellps=bessel +units=m +no_defs) - Projiziert) – darius Oct 1 '18 at 13:38
  • and when i make a rightclick on the layer and click "set csr" and then select the one i want, the image is anywhere but not where it should be – darius Oct 1 '18 at 13:42
  • You have 2 "problems": Setting the CRS to the right one, and then projecting that to your target CRS. So go one step after the other: make a new project, import only the osm layer and your points. See if they match. If not, and you know they both have WGS84 coordinates, try "set CRS for layer", setting both to EPSG:4326 manually. See what happens then in terms of alignment. Add government data, set to 3156, see what happens. Export the 3156 layer to wgs84, using "save as" and setting the CRS in the export dialog. – til_b Oct 1 '18 at 13:55
  • tried it once again - same result... i´ll post a picture of my information boxes... maybe it´s quite easy to solve, but i´m very new to gis... – darius Oct 1 '18 at 14:16
  • 1
    The ortho layer CRS should be EPSG:31256 (not 3156). Use Set Layer CRS to that, and the layer should be placed better. Your custom CRS does not have a datum shift. – AndreJ Oct 2 '18 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.