1

We are running web services in GeoServer 2.14. Loading tiled WMS layers in an openlayers application. Polygons, lines and points. One layer published from a table holding several million records and growing. Backend is PostgreSQL/PostGIS database. Spatial indexes added to all data. Drawing scale limits imposed. The services will load fairly quickly at some points and very slowly at other times. We have not really modified the settings in terms of the connections pool or anything else. The slowness is not my local network, it is definitely specific to the application/web services as I have no issue with other sites. I'm unsure of how to troubleshoot but think that there must be some optimization of the configuration that could take place. I will add that aside from the drawing time, when you click on the feature to access the popup, at times it responds right away, at other times, when the features are slow to draw, it can take awhile for the popup to appear after clicking on the feature.

  • 2
    Log the SQL queries that GeoServer creates either from PostgreSQL side or from GeoServer logs and run them directly with pgAdmin. That should show if the database is slow or if the bottle neck is in some other place. Activate statement logging from PostgreSQL or GeoTools developer logging from GeoServer. – user30184 Oct 2 '18 at 3:01
  • Thanks for the reply, I do test the queries in pgadmin, I don't believe the database is the bottleneck – kflaw Oct 2 '18 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.