2

I have some MapInfo files in my workspace in FME.

The coordinate system of my data is "LL-GDA94", this coordinate system is related to Australia.

My problem is the coordinates of all data in TAB files show somewhere in Japan (but not in Australia).

Is there any solution that can map the coordinates in Japan to Australia?

For example in the following image you can see the coordinate system in _coordsys column and the coordinate of a point in the red circle :

enter image description here 33.922691 (X), 136.059935 (Y)

If I copy that coordinate to the google map, it's somewhere in Japan:

enter image description here

Where it should be -33.830366 (S), 151.22157 (E)

  • 1
    Does the log show any warnings or errors? Can you share those? In what software do you visualise this? (Features placed on Japan.) Can you share a sample of the data? – nielsgerrits Oct 2 '18 at 5:06
  • 1
    I edited my question and brought an example in that. I'm appreciate if you see my question again, thank you – nafis.g Oct 2 '18 at 5:33
  • I think either you're missing a negative sign in your latitude, or your latitude and longitude are reversed. – Fezter Oct 2 '18 at 6:22
  • GDA94 is essentially the same as WGS84 (GPS). So if you have 136.xxx instead of 151.xxx, the problem is not with the coordinate system, but with the data. – CL. Oct 2 '18 at 9:55
  • If this is really the data and coordinate system as you received it, and it should be in Sydney, Australia, then there is clearly something wrong with the coordinates in their files. I would ask your data provider for further clarifications about their coordinate reference system, units, etc. and see if they can explain this discrepancy. – FSimardGIS Oct 2 '18 at 16:56
3

In general there are 2 possible scenarios regarding coordinate system problems:

  1. The coordinate system assigned to the data is not the correct one. For example, the coordinates are in WGS84 but the assigned coordinate system is Pseudo Mercator.

In this case the solution is to change the coordinate system. In FME this can be done with the CoordinatSystemSetter transformer.

  1. The data is in a coordinate system that differs from the coordinate system you (or the software you use to read the data) want. For example the coordinates are in WGS84 but you need the data in Pseudo Mercator.

In this case the solution is to change the coordinates. (Transform / Reproject). In FME this can be done with the Reprojector transformer.

The CoordinateSystemExtractor transformer can help you to determine the current assigned coordinate system.

  • Actually the coordination system is correct but the coordinates are not – nafis.g Oct 2 '18 at 5:07
  • 1
    Yes, but you don't know that the coordinates are wrong. They could be correct, but for a different coordinate system. For example, if I said the data was "LL-GDA94 (12404303.630730629, 2894527.9591711666)" then something is badly wrong. You would say the coordinates are wrong. But in fact the coordinates are correct for your location; they are simply in the coordinate system Australian Antarctic Lambert. Set the coordsys to that and FME will show it in the right place. to be honest, I think it's less likely this is your issue, but you'd be wrong to discount it completely. – Mark Ireland Oct 2 '18 at 15:28
  • I am sure my coordinate is wrong and FME doesn't change any thing. My problem is not FME or what FME does, my problem is the coordinate system of the original files(MapInfo files) is correct because I'm working in Australia coordinate system in zone 55 and 56 but the coordinates in the original files refer me to somewhere in Japan. I tried lots of coordinate system but they didn't work. I think it is my data problem – nafis.g Oct 2 '18 at 22:58
3

There are a few things to try or to consider. Firstly in your screenshot I see that you have the coordinate system as an attribute, but I don't see it in the information window (top right). So make sure that it is referenced there else FME won't be using it:

enter image description here

We also have to consider whether the coordinate system or coordinates are correct (or neither). As @buddiebubba says, you don't really know the coordinates are wrong. They could be correct but the coordinate system is wrongly tagged. Set the correct coordinate system and the data might drop into position.

But, if the coordinates are not what you are expecting (and you are discounting the fact the coordinate system is wrongly tagged), bad coordinates could be the source data is incorrect or FME has misread them.

To me, I think it's unlikely that FME is changing your coordinates, but you could open up the source data in its native environment (ie MapInfo) to be sure.

Alternatively... I can't tell if it's a MIF/MID dataset or TAB. If it's TAB, then FME has three different readers. Firstly try MapInfo TAB (MAPINFO) and MapInfo Tab (MITAB). Then there's also a format called MapInfo Extended TAB (a newer format), which you could try to see if it gives different results.

If all three give the same result then it's even less likely that FME is at fault, and more likely the problem is in the source data. If one is correct but another is a problem, then please let the FME support team know so any issue can be fixed (in the meantime you use the one that works).

If it's the data and simply a case of Lat/Long coordinates being the wrong way around, then you can use the CoordinateSwapper transformer in FME to switch the axes.

IIf it's a case of the sign being wrong on the data (eg you have +33.9 when it should be -33.9) then it's a little harder to fix. The simplest method I can think of is to extract the coordinates to an attribute (with a GeometryExtractor transformer) with a format like GeoJSON. Then use a StringReplacer transformer to place/remove - sign as necessary, and a GeometryReplacer to put that back onto the geometry:

enter image description here

As to how/why 136.059935 becomes 151.22157, I have no idea I'm afraid. Again, if all three FME readers are returning the same value, I'd return to the source data. If you don't have MapInfo to open the files, try using a hex editor to open the files and see if there is a header with the data extents. That at least would be some clue.

  • It is not FME issue , the data that I have has some problems. I opened my files in QGIS and I have same problems with the coordinates. I think maybe there is some way to fix it?! The coordinate system that shows in my screenshot as an attribute is came from 'coordinate system extractor ' transformer and it is the same as 'coordinate system' filed in feature information section – nafis.g Oct 2 '18 at 23:01
  • Then I think you really have to consider whether the data is all wrong in the same way (eg it's positive coordinates when it should be negative) or whether each location is individually wrong in some unknown manner. If the problems are consistent and identifiable, then you can fix them with FME using techniques like the ones above. But if the problems are not consistent (one feature is OK, another isn't) or we don't know why they are wrong (why should 136.059935 become 151.22157?) then you'd have to go to the source of the data and ask for more info. – Mark Ireland Oct 3 '18 at 14:32
1

Is this where your point is supposed to be?

enter image description here

If so, it looks as though your latitude is lacking the leading minus symbol to place it in the southern hemisphere.

  • The wrong data that I have in my files is like this : 33.922691, 136.059935 but the correct data should have this coordinate : 151.22157, -33.830366. – nafis.g Oct 2 '18 at 5:43
  • So, your actual coordinates are somewhere in SA, but they're supposed to be in Sydney? – Fezter Oct 2 '18 at 6:18
  • The wrong coordinate is in northern hemisphere and the correct coordinate should be in southern hemisphere, I think I have to map the coordinate in northern hemisphere to the coordinate in southern hemisphere but I don't know how can I do that? – nafis.g Oct 2 '18 at 6:27
  • Confused. You have 33.922691, 136.059935, but it should be -33.922691, 136.059935? Or -33.830366, 151.22157? – nielsgerrits Oct 2 '18 at 6:43
  • It should be -33.830366, 151.22157 – nafis.g Oct 2 '18 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.