0

I am fairly new to to QGIS and I am trying to create a contoured map from point data. The points are regularly spaced at 3.5 metres apart and whenever I try and run the IDW interpolation in QGIS 3 it creates a layer that with the minimum and maximum value the same and nothing is visible in the screen.

I have tried the same in version 2.18 and it does create a layer with different values, but it is gridded and not contoured.

I have managed to use these tools before with other data sets, but I am properly stumped. I have tried different settings and values but nothing seems to give any different results in either version.

Picture 1 shows the layer from QGIS 3, picture 2 shows the settings from 2.18 and pictures 3 and 4 show the results from 2.18 being gridded with the red points laid over the top

Layer from QGIS 3

Settings

layer from 2.18

[gridded layer[1]

2

When you refer to the output being "gridded", I'm assuming you mean that the output is a raster.

The various IDW Interpolation tools all create rasters as their outputs. You can turn a raster into contours by an additional step, using any of these tools/algorithms:

  • GDAL Contour
  • r.contour
  • SAGA Contour lines

To find these tools, search for "contour" in the processing toolbox.

  • Thank you. I will try this. When I was looking through support docs for this the contoured raster was being created without going through these additional steps. Do you know why this could be required for this data set – Ollie Oct 3 '18 at 8:43
  • I don't think I have been clear with my terminology. In the picture at the bottom you can see the raster that has been created with rectangular cells. I want to produce the raster without these cells. I have tried changing the column number but this hasn't produced better results – Ollie Oct 3 '18 at 18:53
  • Is your problem that the cells are rectangular instead of square? That would have to do with the CRS. – csk Oct 3 '18 at 20:42
  • That is not it. I don’t want to see cells at all, I’m looking to achieve smooth areas. In the image above, on the left side there is a black area. Instead of seeing angular cells along its edge, I’m wanting a smooth line so that I can put a contour along it – Ollie Oct 4 '18 at 5:11
  • Rasters always have cells. If you don't want to see the cells, make them smaller by using smaller cellsize values. – csk Oct 4 '18 at 17:20
-1

You can do IDW interpolation in QGIS with three tools: IDW Interpolation from QGIS Interpolation tool. v.surf.idw from GRASS and GRID(IDW Nearest Neighbor Searching) from GDAL. Each tool has some different parameter settings and could give different result. This post has a good information about IDW and how to perform it in QGIS, including result comparison from those tools. Check it and find out which one is suitable with yours

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.