2

Running Whitebox Tools (v 0.11) on Windows from the official binary.

The ClipLidarToPolygon tool creates an output LAS file with no points and the message There are fewer than two points in the LAS file.

The command I am using is:

whitebox_tools -r=ClipLidarToPolygon -v  --wd="D:\Documents\Dir" -i='StElisAk.las' --polygons='Test.shp' -o='output.las'

Where Test.shp is a single-polygon ShapeFile created in ArcGIS (UTM 6N) which overlaps the sample StElisAk.las file. Naturally I have tried my own LAS and ShapeFiles as well.

Is the ClipLidarToPolygon tool broken, or is it very particular about its inputs and I'm missing something?

1

I tested the ClipLidarToPolygon tool in WhiteboxTools using a test polygon that I digitized for an arbitrary section of the StElisAk.las dataset. No errors were thrown and I received the following result:

enter image description here

I digitized my test polygon in Whitebox GAT and used QGIS to set the projection to CRS EPSG:26906 - NAD83 / UTM zone 6N - Projected (*Whitebox GAT does not allow for re-projection).

Having confirmed that the tool will work with this StElisAk dataset, I can only conclude that the error was the result of the test polygon that you used. I suspect very strongly that it is the result of the projection. That is, if you digitized your polygon in ArcGIS, sometimes when you set the projection, it does so on the fly for display purposes rather than actually re-projecting the Shapefile itself. If you check the .prj file, I wouldn't be surprised to see that your file is actually in geographic coordinates and therefore the LAS file (NAD83 / UTM zone 6N) is not aligned with the Shapefile polygon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.