0

After describing this issue in Qgis: Shape layer turns non-editable if saved filtered

(where the answer basically was "if you filter, don't edit"),

it has happened again (filtering and editing is soo useful that I forgot not to do it!)and I wonder if there is a way to turn editable a shape layer where the Toogle Editing tool remains grey.

My only chance is unfiltering and saving the table with another name, deleting the original table and keeping on working with the new one. But this is not a very pro solution, isn't it?

Does enyone know another way around?

  • One less annoying solution is closing the attribute table and opening it again. It turns editable again. But this is not the optimal solution, as the layer style is lost. – Pescariz Oct 5 '18 at 7:36
0

The reasons why this is happening are explained by Andre in your linked post.

The problem lies not in QGIS but your workflow with shapefiles. If you don't want to use a different format like Andre suggests then you should consider selecting the features you want to edit rather than filtering (using the same expression you are using for filtering). You now have no problem and no need to create a second table (though keeping a copy of the original shapefile is always a good idea). You can also choose to show only the selected features in the attribute table or 'move select to top'. You really don't need to go down the filtering route.

  • That option is not possible as I need to use the select tool within the filtered data. In my precise workflow I need to edit roads once I have filtered the ones I need to edit, but then I need to geographically select them one by one to make changes in each of them. So, working only with selecting data is not an option. – Pescariz Oct 5 '18 at 8:32
  • It is possible - first select by location and then sub-select by attribute (or vice versa). – MappaGnosis Oct 5 '18 at 8:54
  • You can select the data and then use Identify features to geographically identify (click on ) and edit each feature. – she_weeds Oct 6 '18 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.