1

All of the Geopackages stored on one of my drives (D:/) appear to be corrupted, and don't work, but work fine if they are copied to another drive. The other file formats on the same drive all work fine (shape files, tiffs, csv, etc). Any geopackage on my drive D:/ that I've tried to open with QGIS cannot be opened by other software (eg R) until it has been moved to another location.

The error also crops up when I try creating a new geopackage in the drive, but can create them in other locations. QGIS creates an empty geopackage, but then says it's not a valid data source and will not add it to the map.

I can create a geopackage using R on my drive D:/ and it works fine until I try opening it with QGIS, at which point it is not openable by either program.

I updated QGIS from version 3.2.0 to 3.2.3 after this problem showed up, but it did not change the behavior.

Does anyone know why Geopackages would stop working in one location, and how to fix it? Using a different location isn't a great solution because the drive D:/ is the primary drive I use for GIS projects.

  • 1
    What disc format do you have (FAT32, NTFS, HFS+ etc)? – Mapperz Oct 6 '18 at 3:11
  • have you tried changing the drive letter? – neogeomat Oct 6 '18 at 11:51
  • Have you tried different folders in the drive D:/? I am thinking that could a Scandinavian or other less common character in the path cause problems – Orienteerix Oct 6 '18 at 14:21
  • There is nothing in GeoPackage or QGIS that prevents the usage or D-drive. I guess that you are using Windows and it should support nowaday also forward slash in D:/ but try still the native D:\ style. Have you tried that everything works fine if you create the GeoPackage file directly into some other drive? You write only that it works if you copy it into another drive. Does the copied GeoPackage open normally with QGIS? – user30184 Oct 8 '18 at 8:49
  • Answering the questions: the format on the drive is exFAT. I my computer is running Windows 8.1. I have tried several different folders in the offending drive, and they all show the same behavior (ie shapefiles work fine, but geopackages cannot be loaded). I also get the same behavior if I try to create a geopackage in the root folder of D: (eg D:/test.gpkg) Everything works fine on other drives (I can create, use, modify etc. geopackages on for example drive H:) I've tried using both slash styles in the file mapping, but it doesn't seem to make any difference. – Brian Fisher Oct 8 '18 at 15:45
0

Change the drive letter to a different drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.