3

I am using QGIS 3.2.

I am trying and trying to get a line from my points to my labels! I have not moved the labels manually, but they are offset using the "offset from point" choice for placement. There seems to be a new field in the attribute table called "auxiliary_storage_labeling_offsetquad". I activated the little data defined box and chose the aux storage for the Field Type for everything relevant - see below (maybe more than needed?)

enter image description here

I am trying to use the Geometry Generator and have tried many slight variations in the formula. I tried creating new fields of x and y in my table and defining the labels with those, as suggested in some tutorials (i think for older versions). Heres my latest attempt as an example

enter image description here

I don't know what I'm doing wrong and don't know what else to try.

  • Perhaps this thread will help gis.stackexchange.com/questions/285102/… – she_weeds Oct 6 '18 at 8:44
  • Thanks I have looked at that thread and all relevant ones i could find. To me it looks like i am following all the steps correctly but it's not working still. Is there something about what type of layer, or project properties, or i don't know what that could be preventing lines from appearing? – strom Oct 6 '18 at 15:32
  • On 3.6 and I can't get lines to show up either. I just tried @Kazuhito 's suggest too. – Jim Garner Apr 3 at 4:08
1

There were a couple of changes made to Easy Custom Labeling tool.

  1. associated field names for X, Y coordinates of labels have changed to "LblX" and "LblY".
  2. the output comes with Line geometries.

So, please try make_line(start_point($geometry), make_point("LblX", "LblY")) instead.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.