0

I have a setup that uses Oracle database->GeoServer->OpenLayers->my JavaScript.

I use the UTF-8 character set in GeoServer and the JavaScript layers. The Oracle instance is configured to use WIN1252 (NLS_CHARACTERSET=WE8MSWIN1252).

So, when I make a request from the JavaScript with the CQL_FILTER with characters such as ç, à, .. I get no results from the database because of the encoding.

What is the best way to deal with this problem of multiple character sets? My opinion is changing the database charset to UTF-8, but unfortunately is to risky, because I'm not the only one using it.

Any suggestions?

0

Configuring Tomcat's URI encoding to UTF-8 solved the problem.

Configuring Tomcat's URI encoding:

By default, Tomcat uses ISO-8859-1 character encoding when decoding URLs received from a browser. This can cause problems when your encoding is UTF-8, and you are using international characters.

  • Edit conf/server.xml and find the line where the Coyote HTTP Connector is defined. It will look something like this, possibly with more parameters:

    <Connector port="8090"/>
    
  • Add a URIEncoding="UTF-8" property to the connector:

    <Connector port="8090" URIEncoding="UTF-8"/>
    
  • Restart Tomcat

...

https://confluence.atlassian.com/display/DOC/Configuring+Tomcat%27s+URI+encoding

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.