1

I exported my webmap, using QGIS2web.

The QGIS2web already has a search bar, but the placement icon when I search, as it applies to my project, always shows below my uploaded raster images. When I zoom in it vanishes, because the size of the search icon reduces, and lies below my raster files. I used a series of images to explain.

Figure 1: I highlighted my uploaded polygon at the right bottom corner. The underlying map is OSM.

Figure 2: I searched for a feature, and the box suggested related features for me in the top left area.

Figure 3: haven clicked the enter icon to validate my search, I unchecked the images, showing the underlying OSM. You should be able to see the blue dot representing the response of the search

Figure 4: As I zoomed inward, the blue dot becomes clearer, radiating from beneath my polygon that I didn't uncheck.

Figure 5: As I zoomed further inward, the search response icon becomes smaller than my individual raster, therefore unable to show, as its default is to show under my polygon (this is what I want to correct. I want it to show above my images.)

Figure 6: To prove that it was underneath, as I unchecked my raster images, it became more clearly visible. Isn't it possible to just have the search function highlight my search feature in a different color, instead of using a dot to point to it, as is the case here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.