First of all I must say I love new legend designer. It is great to have finally better tool for positioning and even some changing the size of lines and region symbols, hooray. Big step for MapInfo to be one day user friendly professional tool for map layouts.

But... when I use Legend Designer all content of legend window is automatically converted to bitmap for layout print/export to PDF. Is there some option to turn this off and keep text/vectors? I found out this way I can't use it at all with symbols.

Problem of Legend Designer

  • 3
    In my opinion, Legend Designer is just another bandaid on a poorly implemented software program. Yes, it's a big improvement on the old legend, but it is still nowhere near as flexible as ArcMap's Legend Wizard. If I open an existing workspace from a previous version of MapInfo, and try to edit the legend, I don't get the new legend designer. I have to create a new one. The features released in this update are not even worth mentioning about. I wonder why we still pay maintenance fees. Sorry for the rant, probably not the place for it. But I had to put it out there.
    – Fezter
    Jul 19, 2012 at 4:36
  • 1
    @Fezter I have same feeling but our company is using Mapinfo for many years so it is not easy to get rid of it. Well, I am going to rethink it again. Thanks for comment.
    – Miro
    Jul 19, 2012 at 12:20

2 Answers 2


Kalu to mapinfo-l: Apparently not. I contacted MapInfo about this a couple of weeks ago. I got the following response:

"I have received some feedback from engineering about the new Legend Designer window. This window is actually rasterised when displayed within MIP so it is non-trivial for MIP to then convert the window back to a vector format. This feature will be included in subsequent releases of MIP however this enhancement has not been scheduled as yet. The current workaround is to use the old Map Legend window."

I've created a request in the MapInfo Community Ideas forum to request them to make this change. See and vote for: http://pbinsight.force.com/pbideas//apex/ideaView?id=08780000000EMmI&returnUrl=%2Fapex%2FideaList%3Fc%3D09a800000009It0%26category%3DMapInfo%2BProfessional%26sort%3Drecent


  • <sarcasm> Very nice </sarcasm>
    – Nathan W
    Jul 20, 2012 at 1:02
  • 1
    Fixed in patch from 12/2012. Though symbols in legend are still rasterised. But well, if you can't use even simple thing like layer opacity without getting the whole layout rasterised in PDF, it doesn't matter anyway. But to be fair, with improvement of tools in few last Mapinfo versions I don't feel need for postprocessing layouts in graphics software anymore, at least not in company I am working at now. So one plus point from me this time.
    – Miro
    Jan 16, 2013 at 23:03

Have you Enabled Enhanced Rendering? If so, you might want to turn it off.

  1. Options
  2. Preferences
  3. Styles
  4. Untick "Enable Enhanced Rendering"

That has worked for me in the past for similar issues. Haven't tried it with the new lengend designer.

  • 1
    Thank you but I tried this before with no success. I have got the reply which explain why it is happening elsewhere so I am going to post it here as answer. Thanks again.
    – Miro
    Jul 19, 2012 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.