1

I am trying to interpolate points and then clip the interpolation with a Raster> Extraction> Clipper. I receive an error code after trying to mask over the region I am interested in. Would you possibly know what the error code means?

It says Ring Self Intersection at or near point. I tried to break it down to smaller chunks, but I get the same error code.

Warning 1: Ring Self-intersection at or near point -53.756366999999955 48.50326200000012
ERROR 1: Cutline polygon is invalid.

enter image description herePoints I am interpolatingMy results on the right.

Fixed the geometry with a the polygon validator. The interpolation is still a little funny (image on the right is what I have. Image on the left is what I want to achieve)

Additional Images and link to tutorial: https://www.qgistutorials.com/en/docs/interpolating_point_data.html

Setting for mask Setting for contour

Update after follow Kanban's recommendation to make the resolution smaller. Resolution was set to .2 in the interpolation process.

You can see USA

0

Not working in this case, see BERA's comment. Answer keeped in case it is useful for someone


It looks like your geometry might be malformed.

In order to verify that, you can create a buffer of your mask layer. The distance does not have to be huge, 1m is enough.

Hopefully this will discard any self-intersection by creating 2 distinct rings, allowing you to extract your region of interest.

The error code means that somewhere, one of your rings (holes in the polygons) is cutting its owned border, or has an 8 shape, the center of the 8 being the self intersection. If your data comes from a vectorised raster, it is pretty common, and quite annoying as you may have lots of these. Hence the buffer quick fix to see if this is the real issue or if there is another issue with your data.

  • Thanks. I downloaded the shape file online. I tried the buffer, but that did not work. I was able to use the validator input from QGIS to separate the bad polygons after and clip it from that polygon. The interpolation looks a little strange still. – Cynthia W Oct 16 '18 at 2:40
  • Which tool are you using to interpolate? I think that it would be another question. However, you can put the link in the comment, I'll try to have a look. Please describe the tool you've been using as well as your parameters. – Kantan Oct 16 '18 at 7:28
  • I am using this tutorial: qgistutorials.com/en/docs/interpolating_point_data.html – Cynthia W Oct 17 '18 at 13:10
  • I am not sure if it's because I am using 15 points that sit within the boundary to calculate the interpolation. The tutorial uses the edge boundaries (It looks like)-- I figured the mask would cut off any excess/stretch the interpolation to its extents. As for mask. I am using Ratster > Extraction > Clipper. In that pop up, I select mask layer. I included some more image in the question. – Cynthia W Oct 17 '18 at 13:16
  • 1
    As always, the smaller your resolution, the better the shape will be approximated (see the evolution between your two first attempts). However, the size of your files increases with a power 2. (a file with a resolution 3x thinner will be 9 times bigger) – Kantan Oct 19 '18 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.