0

I created a new toolbox with a script tool that successfully works for me when I run it. I have it saved in a shared folder that my coworkers can access but when they try to run it, it doesn't work. One coworker gets an error message that says they can't locate the Python script even though when they checked the properties it showed the correct file and when another coworker runs it, it stuck in a loop and nothing happens.

I have no idea why it works for me but no one else.

  • 4
    Are you sure there are no hardcoded file path relative to your setting (like network drive letter) in your script or toolbox or that the script need to write on an emplacement where your coworker doesn't have proper right ? – J.R Oct 12 '18 at 16:23
  • 1
    What you might the "p" drive (or what ever letter you have used for your network drive) may not be the same for other users... For example they access the same location but call it the z drive. – Hornbydd Oct 12 '18 at 17:00
  • What is the precise wording of the error? I think you should try writing a simple test tool that illustrates the same error so that you can present that code here. – PolyGeo Oct 12 '18 at 19:39
1

The python script has to be pathed to the shared folder that the geoprocessing tool resides in, not by the partition. For instance if you have source script set to C:/myscripts/python then when the tool launches and tries to find the script that its sourced to, so it can run it will look on that users computer for that path C:/myscripts/python. And then of course the path will not exist. To fix this, on your PC in ArcCatalog, right click the tool, go to properties, then Source tab. Change the path for the script to the network path. Example //yourcomputername/C$(orpartitionletter)/sharedfolder/pathtoscript. Then save the tool. This will allow other users to run the tool in their instance of ArcCatalog, because it will use the shared folder that you created. Also if the script relies on any local folders they will need to be repathed to the network path pattern referenced above.

  • Thanks, I looked at my links and I think they should match everyone else's. Next week I will check my coworkers computers, maybe that will help me identify what isn't matching up. – M.Welch Oct 12 '18 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.