1

Hoping someone can help me on this.

So I've installed Geoserver 2.11 and am able to produce proper XMLs from my GetCapabilities. For example:

<?xml version="1.0" encoding="UTF-8"?>
<Capabilities version="1.0.0" xsi:schemaLocation="http://www.opengis.net/wmts/1.0 http://schemas.opengis.net/wmts/1.0/wmtsGetCapabilities_response.xsd" xmlns:gml="http://www.opengis.net/gml" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:ows="http://www.opengis.net/ows/1.1" xmlns="http://www.opengis.net/wmts/1.0">

This works fine for me inside my ArcGIS runtime.

But when I use version 2.13+ it is missing the XML encoding at the header of the GetCapabilities which is no longer recognized by my ArcGIS runtime. I have tweaked every setting I could think of but cannot find a solution to this. This is what my GetCapabilities looks like in the newer versions of 2.13+. Notice there is no XML encoding, so my ArcGIS runtime does not recognize it as a valid XML. Does anyone have any suggestions? I have lost hours on this seemingly silly thing.

<Capabilities xsi:schemaLocation="http://www.opengis.net/wmts/1.0 http://schemas.opengis.net/wmts/1.0/wmtsGetCapabilities_response.xsd" version="1.0.0"><ows:ServiceIdentification><ows:Title>GeoServer Web Map Tile Service</ows:Title>
  • Hmm... I just tried on a 2.15.x and the header is there, also quickly checked the code, the line that generates the header is there and has not been modified since 2014. Are you sure there is nothing else going on (proxies and the like) removing the header? – Andrea Aime Oct 18 '18 at 18:03
  • Hi Andrea. I appreciate you looking at this. Can't imagine it is. I installed 2.14 originally and it didn't work. I would get the GetCapabilities with no xml encoding. Went back down to 2.11 and boom it popped right up. I tried every single setting and config I could think of. Also tried 2.13 and same thing no Xml header. – zincalloy Oct 19 '18 at 1:16
  • Hi Andrea, Here is a screenshot of how it looks for me. I just installed 2.14 on my local desktop, fresh installation and tried it. imgur.com/a/uI7q2GD You can see what I mean. If I do the same thing with 2.11 it will actually prompt me to download a proper XML. – zincalloy Oct 19 '18 at 1:55
  • What you have there is just the browser formatted version of the XML, check its source to confirm. – Andrea Aime Oct 19 '18 at 6:15
  • I just downloaded a 2.14.0 and checked, the formatted version states there is no stylesheet to display the XML (which has nothing to do with the xml declaration being present or not), and "show source" shows the xml declaration right at the top of the file. You are assuming the XML declaration is to blame, but did you check there is nothing else that's different? Does ArcGIS provide any log as to what it thinks is not valid? – Andrea Aime Oct 19 '18 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.