2

I have been running my ArcMap on my new work computer for a month or so, it went fine. But since last week, ArcMap becomes slower whenever I load the map/georeferencing, these days when I georeference an image, it keeps loading and sometimes ArcMap will even stop responding for a while.

My daily tasks involve in making temporary selection from layers, therefore I have many temp layers (I'm not sure if that's the reasons why it lags)

I have tried to clear cache from a ArcMap options and turn off snapping.

  • Have you built pyramids on the image? Is the file local or are you accessing over a network? If you don't need your temp layers after you close ArcMap consider using in_memory workspace for geoprocessing tools - they're self-cleaning, which can be a good thing but can also be a curse. – Michael Stimson Oct 16 '18 at 3:57
  • Hi thanks for the answer, i remember i get to choose whether to build pyramids on image or not, now i dont see such option when i import a TIFF. Most of my files are local but some are connected to our NAS server. May i also ask how do i use in memory workspace? i am not familiar with what that is, thanks for helping! – Dixbe Oct 16 '18 at 4:17
  • You may have checked no, and don't ask me again gis.stackexchange.com/questions/123829/…, use ArcCatalog to look at the properties of the raster and see if the pyramids are built and if they aren't build them. You will probably get better performance from local rasters compared to rasters on a NAS as your bandwidth depends on what everyone else is doing over the network. Read desktop.arcgis.com/en/arcmap/10.3/analyze/modelbuilder/… about the in_memory workspace. – Michael Stimson Oct 16 '18 at 4:56
  • 1
    Also, clear Results (Results window) and uncheck log geoprocessing results (geoprocessing options). Avoid big vector layers, clip them first. – FelixIP Oct 16 '18 at 5:00
  • 1
    The fact that access changed indicates something other than ArcGIS may be involved (anti-virus, OS patch inflict, ...). You should engage your IT staff in this as well. – Vince Oct 16 '18 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.