0

I'm trying to compute the shortest path between about 10'000 location-pairs. I've prepared my vector map as described in the documentation. I can calculate shortest path on about 1'000 location pairs exactly once per session. If I run the same command again, or I run the command on a larger subset than 1'000, GRASS GIS crashes. If I restart GRASS GIS, I can run the command again.

Note that it does not matter which subset I run my command on: It works once for 1-1000, 500-1500 etc. So there is nothing special about the entry #1001. The command that I'm running looks as follows:

v.net.path input=connect_nodes@data output=test arc_layer=1 node_layer=2 file=C:\Users\paths_1-1000.txt --overwrite

Like I mentioned, if I run this command again in the same session, the software crashes. If I store more than 1'000 location pairs in the txt file, the software crashes. The file paths_1-1000.txt looks like this (coordinates in EPSG 2056):

1 2723662 1120315 2722802 1117241
2 2566308 1118418 2568092 1113171
...
999 2692291 1179213 2690489 1176032
1000 2610343 1212104 2608113 1210953

Maybe "crashing" is not the right term. The GRASS GIS GUI still reacts, and I can run some commands.. I just cannot run v.net.path again.

Does someone know how I might be able to solve this issue? I don't know where to even begin to start looking!

The error message in the output window looks as follows:

Exception in thread Thread-18:
Traceback (most recent call last):
  File "C:\OSGEO4~1\apps\Python27\lib\threading.py", line
801, in __bootstrap_inner
    self.run()
  File "C:\OSGEO4~1\apps\grass\grass-7.4.1\gui\wxpython\core
\gconsole.py", line 156, in run
    self.resultQ.put((requestId, self.requestCmd.run()))
  File "C:\OSGEO4~1\apps\grass\grass-7.4.1\gui\wxpython\core
\gcmd.py", line 614, in run
    self._redirect_stream()
  File "C:\OSGEO4~1\apps\grass\grass-7.4.1\gui\wxpython\core
\gcmd.py", line 643, in _redirect_stream
    self.stderr.write(line)
  File "C:\OSGEO4~1\apps\grass\grass-7.4.1\gui\wxpython\core
\gconsole.py", line 303, in write
    self.message += line.split(':', 1)[1].strip() + '\n'
IndexError: list index out of range

I'm running GRASS GIS 7.4.1 with

Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)
  • Have you tried reducing the dmax value to something lower than the default 1000? – Hasnein Tareque Oct 25 '18 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.