0

I am trying to use Arc's (v.10.2) "Convert Coordinate Notation Tool" to convert UTM coordinates into WGS84. The UTMs are in one column of an Excel spreadsheet as follows:

UTM
346677 E 5293198 N
345854 E 5294018 N

Tool Parameters fed to the tool:

Input Table: Sheet1$
Input Coordinates System: NAD 83
Output Feature Class: location of my chosing
Output Coordinate System: WGS 84
Input Coordinate Format: UTM_ZONES
X Field: UTM
Y Field: grayed out
Output Coordinate Format: DD_2

When I run the tool I get the generic error

"ERROR 999999: Error executing function. Failed to execute (ConvertCoordinateNotation)."

so I don't know for sure what the problem is but my first thought was that it might be that the tool doesn't like the format of the UTMs in my table. Esri's documentation for the tool didn't offer any direction on proper UTM format, saying only:

UTM_ZONES —The letter N or S after the UTM zone number designates only North or South hemisphere.

So, is there a problem with the UTM format in my table?

  • 1
    I think the problem is the cells are being called 'text' because they contain letters and you don't have the proper header row. Perform a find & replace on ' E' and ' N' with '' then change the header row to Easting, Northing to put your Excel sheet into a format that ArcGIS will be able to understand. If the values are all within one cell you will need to break the cell up into two columns so that Esri can understand your input. – Michael Stimson Oct 17 '18 at 23:40
  • @MichaelStimson When I fill in the parameters in the tool dialogue window, for "Input Coordinate Format" I am choosing "UTM_ZONES". As soon as I do that the "Y Field" parameter becomes grayed out. In other words, the tool assumes both Easting and Northing are in the same field, and it only looks at the field you specify in the "X Field" parameter. So apparently I need both Easting and Northing in the same field, just not sure if the format (above) is bad... e.g. do I have a space where I shouldn't, etc.? – Waterman Oct 17 '18 at 23:46
  • 1
    No, ArcMap expects only one field for UTM_ZONES, the issue is that the format needs to be the following: 20N 346677 5293198, so Zone number, N or S for hemisphere, space, Easting, space, Northing. From ESRI Help: 'For GARS, GEOREF, UTM_ZONES, UTM_BANDS, USNG, and MGRS, this field contains an alphanumeric system of notation in a single text field.' – FSimardGIS Oct 18 '18 at 1:17
2

Indeed, you will need to adjust your format in your Excel sheet to make it work.

The format needs to be the following: Zone[N | S] Easting Northing,

Example: 20N 346677 5293198

ArcMap cannot interpret the coordinates, for one thing, because you did not provide the zone in your list. ArcMap needs to know in which of the 60 zones and 2 hemispheres your points are. Also, you should remove the letters E and N after the coordinates, and put a single space between both coordinates.

First, make sure you know the zone of your points and that they are all in the same zone. If you don't know the zone, you can use online tools such as This one

Then, assuming that your data starts at cell A2:

  • Write this formula in the adjacent cell B2: =CONCATENATE("20N ",A2), copy down until the last record. (Replace 20N with whatever your correct zone is)

  • Select data in column B > Copy and Paste values in column A. Delete column B.

  • Use Find and Replace to remove your E and N (mind the spaces) : Find: ' E ' (space, E, space) Replace with: ' ' (space), then Find ' N' (space, N) and replace with '' (nothing, leave textbox empty)

  • Perfect. I figured it had to do with properly formatting the UTM coordinates. Much appreciated. – Waterman Oct 18 '18 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.