2

When starting up QGIS 3.2.2 (also tested with 3.2.3), I get the following message in the "Plugins" Log Message Window:

2018-10-18T08:03:48     WARNING    Failed to load C:/OSGEO4~1/apps/qgis/plugins/grassplugin7.dll (Reason: Cannot load library C:\OSGEO4~1\apps\qgis\plugins\grassplugin7.dll: Das angegebene Modul wurde nicht gefunden.)
2018-10-18T08:03:48     WARNING    Failed to load C:/OSGEO4~1/apps/qgis/plugins/grassprovider7.dll (Reason: Cannot load library C:\OSGEO4~1\apps\qgis\plugins\grassprovider7.dll: Das angegebene Modul wurde nicht gefunden.)
2018-10-18T08:03:48     WARNING    Failed to load C:/OSGEO4~1/apps/qgis/plugins/grassrasterprovider7.dll (Reason: Cannot load library C:\OSGEO4~1\apps\qgis\plugins\grassrasterprovider7.dll: Das angegebene Modul wurde nicht gefunden.)
2018-10-18T08:03:48     INFO    Loaded mmqgis (package: mmqgis)
2018-10-18T08:03:50     INFO    Loaded Networks (package: networks)
2018-10-18T08:03:50     INFO    Loaded QuickOSM (package: QuickOSM)
2018-10-18T08:03:52     INFO    Loaded QuickMapServices (package: quick_map_services)
2018-10-18T08:03:52     INFO    Loaded DB Manager (package: db_manager)
2018-10-18T08:03:52     INFO    Loaded MetaSearch Catalog Client (package: MetaSearch)
2018-10-18T08:03:54     INFO    Loaded Processing (package: processing)

And sure enough, I cannot use the GRASS GIS Plugins. I also have QGIS 2.18.24 installed, the plugins are fully available there. Any idea what the issue might be?

EDIT:

I also tested with OSGeo4W Network Installer (64 bit), with the same result. Also note that grassplugin7.dll, grassprovider7.dll and grassrasterprovider7.dll are available in the folder C:\OSGeo4W64\apps\qgis\plugins

enter image description here

EDIT 2:

Here are my MSVC++ Versions enter image description here

5

Ok, this is slightly embarrassing but I'll post the answer here anyway in case someone is as blind as I was. Apparently, there are two QGIS executable files: C:\OSGeo4W64\bin\qgis-bin.exe and C:\OSGeo4W64\bin\qgis-bin-g7.4.1.exe. In Windows, when firing up a program via the Windwos startup button, it runs qgis-bin.exe by default and GRASS does not work. When you run qgis-bin-g7.4.1.exe however, it GRASS works.

I'll show myself out

0

It looks like a faulty installation. I faced some plugin issue with OSGeo4W installation in windows OS whereas my Linux system is all good.

If there is not any specific reason to stick with 3.2.2, I would suggest to download and install the standalone version of QGIS 3.2.3-Bonn with GRASS 7.4.1.

Its running all fine in my Windows 10.

  • Thank you for this answer. I uninstalled both QGIS Versions 2.18.24 and 3.2.2 and installed 3.2.3 with GRASS 7.4.1. The issue persists... Any ideas? – Ratnanil Oct 19 '18 at 5:44
  • Have you checked if any of the previous dlls are sitting in the sytem like Appdata folder or so. Do a quick search to check if the DLLs are only on one place. – Hasnein Tareque Oct 20 '18 at 13:35
  • Also make sure the MSVC++ runtime is uptodate. I have experineced a lot of problems of dlll loading where the installed MSVC++ is different than which was used to comile the dlls. The MSVC++ that comes with the GRASS 7.4.1 should be fully compatible with GRASS dlls. Also make sure the Windows registry is not carrying a older/imcompatible MSVC++. DLLs are absolute pain now a days. – Hasnein Tareque Oct 20 '18 at 13:42
  • To your first question: I searched my entire Harddrive and found the dll's at two locations. Once for each QGIS Installation. For QGIS 2.18 it's locatated here C:\Program Files\QGIS 2.18\apps\qgis-ltr\plugins while its located here C:\OSGeo4W64\apps\qgis\plugins for QGIS 3.2.3. – Ratnanil Oct 22 '18 at 12:10
  • To your second question: I've added my MSVC++ Versions in the original question: – Ratnanil Oct 22 '18 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.