2

I have read in several places that the best way to create a buffer around a vector point is using the MMQGIS plugin.

I want to create buffers in London locations within a few metres of each other which meant that Vector > Geoprocessing tools > Buffer is not accurate enough using decimal degrees.

I've downloaded MMQGIS and I understand how it works in principle, however when I create my buffer, even of only 1km it ends up sitting as one big lump west of South Africa and not in London.

I have checked the CRS for each of my layers which is WGS84 (EPSG:3857). I need to use this as I'm working with a unique historic map which has been formatted to this CRS.

When I checked my project CRS (Project > Properties > CRS) the project is set to Generated CRS (User:100000). I changed the CRS to WGS 84, but this just warped the map and the buffer was still west of South Africa. I have therefore changed the project CRS back to Generated CRS.

Could anyone explain to me the MMGIS fields and where I may be going wrong?

Or an alternative programme I could use to get my buffers down to metre accuracy?

I'm quite IT literate, but coding etc is a little beyond me.

I am working with QGIS3.2.3-Bonn on Mac.

  • 1
    I think the issue is about the CRS, therefore I suggest to make an acquaintance with these articles: Understanding QGIS buffer tool units?, Does QGIS Buffer Tool use units of CRS?, Create buffer in meters?. and A easy way to create buffer in QGIS?. – Taras Oct 18 '18 at 10:27
  • Thanks @Taras, I had read some of those already, but caught up with the others. I 'saved as' the layer to EPSG: British National Grid 27700. Projeciton of vector points line up with my original WGS84 projection, which is great, however when I then use MMQGIS to buffer, the geometry switches back to WGS84 (according to the layer properties). I then tried 'save as' on the buffer layer to make it 27700, but it stills stays in the ocean by South Africa. Any more ideas? Have I missed a setting somewhere? Would any of my underlying maps have an effect? – Rhian Addison Oct 18 '18 at 11:02
  • "...the geometry switches back to WGS84..." Do you end up with the same result even after using a regular QGIS buffer (not MMQGIS plugin)? You can additionally try to use GRASS GIS library v.buffer which is placed Toolbox. – Taras Oct 18 '18 at 11:12
3

It has nothing to do with MMQGIS, but all with the CRS.

If it is projected in WGS84 and you set your buffer distance as 1000, then it will buffer with 1000 degrees. If you want to buffer with metric values, you have to convert your data.

This can be done by 'Save As...'.

Save as 1

You get a dialogue where you can choose a CRS fitted for your area.

Save as 2

  • Sorry @PieterB, I'm not clear - are you referring to 'save as' on the layer I'm trying to buffer or 'save as' the entire project and change to metric? I've looked at both and can't see where I can have the opportunity to change to metric. Would you be willing to talk me through the menu options you are referring to? – Rhian Addison Oct 18 '18 at 10:02
  • ... When I go to Project>Project Properties>General>Measurements it is already set up as WGS84 with meters as the unit for distance measurement. – Rhian Addison Oct 18 '18 at 10:03
  • you have to save your layer to a new projection – PieterB Oct 18 '18 at 10:30
  • Just to extend @PieterB answer, the layer should be saved with a new CRS which maintain metric units, because the buffer size is always applied in the layer CRS units. – Taras Oct 18 '18 at 10:32
  • (Repeated from above) I 'saved as' the layer to EPSG: British National Grid 27700. Projection of vector points line up with my original WGS84 projection, which is great, however when I then use MMQGIS to buffer, the geometry switches back to WGS84 (according to the layer properties). I then tried 'save as' on the buffer layer to make it 27700, but it stills stays in the ocean by South Africa. Any more ideas? Have I missed a setting somewhere? Would any of my underlying maps have an effect? – Rhian Addison Oct 18 '18 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.