I'm trying (unsuccesfully) to place the attribute table next to a map containing the same in print composer. Let's say for example my map in the primary window contains 6 districts and my map in the print composer only shows 1 district. If I unselect the "show only visible features" box then my table shows all entries (e.g. from 6 districts). However when I select the "show only visible features" it shows only the title row of the attribute table: it does not show any of the data entries.

What am I doing wrong?

2 Answers 2


Under Settings -> Options, General Tab you can select the behaviour of the attribute table. You might scroll down to see it.

These settings overrides the selection in the attribute table itself.


there is a control for how many rows are shown, often it defaults to 0. Also if your projections are different, if the layer the attributes are coming from is different to the crs of the map, then this feature may not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.