2

I'm trying to produce a high quality image of a geological structural map provided for at this exact WMS link (The link includes the dimensions I wanted and the max possible resolution they provide)

http://maps.greenmin.gl/geusmap/ows/32624.jsp?nocache=nocache&whoami=[email]&LAYERS=grl_geus_500k_geology_map&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&FORMAT=image%2Fpng&TRANSPARENT=true&STYLES=&SRS=EPSG%3A32624&BBOX=499980.0,7190220.0,609780.0,7400040.0&WIDTH=1500&HEIGHT=3000

I tried asking the question here, but had no luck with anyone providing me with an answer. I've also tried working it out like this post, without luck. So instead I've tried a different approach of using the Layer -> Save as function in QGIS. Which is partially successful. I am able to output a geo referenced TIFF of the region with the desired dimensions. But for some reason that is beyond me, the file size is 92 gb and every program I try to open it in, chokes hard. This map is an exact matching overlay of a Sentinel-2 satellite image, in high quality, geo referenced and with a file size of about 1 gb. It ought to be possible for me to do something like that.

It would also be fine if I could get it without a georeference, I can add that manually. I just cannot fathom why it is so hard to have QGIS output a large dimensional image without producing ridiculous file sizes.

Has anyone dealt with anything like this and found a suitable solution or work around?

enter image description here

  • Hello Peter, also the create options of the Save raster layer as ... makes compressing available on the image. – Jakob Oct 23 '18 at 12:50
  • Hi @Jakob, I tried doing that. But every time I tick it and run it, it pops an error saying "Cannot validate creation options" – Kongie Oct 23 '18 at 13:24
2

You are asking (in all these questions) for an image that is 200k*100k pixels in size - that is 20,000,000,000 or 20 billion pixels each with 3 bands so 60 billion bytes (or worse floats or doubles) so it is going to be a big file unless you add some compression.

If you are basing it on the WMS request then asking for more than 1500 by 3000 pixels is a waste anyway as that is the resolution you get.

  • Doh... I've been stuck on this for days now... And some times all you need is a second pair of eyes. The image is being output with an 0 to much at the end of the x,y dimensions. I didn't notice that until you mentioned it. And as you said I might as well reduce it even further. Thank you Ian. – Kongie Oct 23 '18 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.