1

I downloaded QGIS version 3.2 and (I think) followed the install directions correctly: first I installed Python 3.6 from the Python website, then I installed GDAL, but when I install QGIS I get the errors mentioned elsewhere in the forum, "QGIS requires Python 3.6". From reading other posts, it seems like installing Python directly from the Python website was the solution to others with the same error - this may have corrected incorrect paths.

Any thoughts on what else I can try?

enter image description here

enter image description here

  • /usr/bin/python or pythonw is the Python version 2.7.x pre-installed by Apple. /usr/local/bin/python3 is the Python 3.6.x version – gene Oct 23 '18 at 15:06
  • Thanks for your response Gene. In the Python Preferences I changed the path to "/usr/local/bin/python3" in Script, GUI Script and Bytecode Document, then I reinstalled GDAL (not sure if this was necessary) and then tried to install QGIS, but I still get the same error. Any other ideas of what I'm missing? Thank you! – JimO Oct 23 '18 at 15:40
  • Oops. From reading another post, I now realize that I accidentally installed Python 3.7 instead of 3.6. With Python 3.6 now installed, I successfully installed QGIS 3.2. Thank you! – JimO Oct 23 '18 at 16:19
1

I faced the same problem: On Mojave the default python version seems 3.7 and As downgrading to python3.6 with brew switch python 3.6.x, didn't make the installer error go away I installed qgis over brew:

brew install gdal
brew cask install xquartz
pip3 install matplotlib
pip3 install psycopg2
brew tap osgeo/osgeo4mac
brew install qgis3

The version I ended up with is 3.4.1-Madeira

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.