2

I've run into this issue recently wherein I run the Con tool on a 32-bit raster (TIFF format) to change some absurdly high/low values to 0 and I get a 64-bit raster (TIFF format) out the other side. This is an issue because some of the programs I use don't like 64-bit rasters and it's unnecessary for the data. I downsize it back to 32-bit using translate in QGIS. but then I get -inf values as nodata.

Rather than having to fix it, I would like to find a way to prevent ArcGIS Desktop 10.6 from creating a 64-bit raster in the first place.

How do I do this (if it is possible to do)?

EDIT: I've attempted to update statistics. This does not seem to do anything.

  • 2
    I've never had ArcGIS create a raster with higher precision than I requested, though it has created higher precision than I had intended (but didn't provide the right parameters). In order to identify what has gone wrong, you need to provide far more details on what exact parameters were used. – Vince Oct 24 '18 at 16:50
  • I'm not sure what details would be helpful. the raster I'm using has a data range of 0 - 100000. At some point in the raster's history, it's had a value of -inf. Now despite the raster not currently having that value. it registers as having that value after I perform the con. I'm attempting to remove that via a con statement. Expression is "VALUE" < 100000 AND "VALUE" > 0. And it become 64-bit after the con statement. – NorthLand Oct 24 '18 at 18:24
  • update the statistics – Vince Oct 24 '18 at 20:18
  • I tried that. It did not appear to do anything. – NorthLand Oct 25 '18 at 15:05
  • Please use the edit button beneath your question to revise it with any requested clarifications. – PolyGeo Nov 4 '18 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.