I am trying to use the QGIS plugin GeoSearch. Every time I type in an address and hit search, nothing happens. When I first installed it a few months back, it worked like a charm, I dont know why one day it just wouldn't work. I have a valid google API because I use google basemap layers every day.

Things I've tried: -I've uninstalled/reinstalled -When I use the 'Search On Google Web Map' feature, It opens to the address immediately -tried different Geocoders with no response.

geosearch plugin

QGIS version : 2.14.10-Essen OS: Windows 7 64-bit edition

  • 2
    The plugin's V3 geocoder appears to support custom API keys but the plugin GUI doesn't appear to provide any way of providing these, so it'll be using a demo API key (or no API key at all). Have you seen any way of providing your API key at all? This might need some Python hacking on your local plugin installation to work.
    – Steven Kay
    Commented Oct 25, 2018 at 18:11
  • I ended up downloaded the plugin OSMsearch to replace Geosearch. I'm afraid my antiquated version of QGIS might be to blame. Thanks for answering @StevenKay
    – Shpoogen
    Commented Oct 26, 2018 at 21:52

2 Answers 2


I have tried to edit googlev3.py and google.py in order to set the variable secret_key after activating billing in Google Cloud Platform / Geocoging API, but nothing is happening. It seems this very good plugin is now deprecated. We hope somebody correct it and reach to migrate it to QGIS 3.x

  • 1
    i think you're right. I'm now using the Experimental plug in, OSM place search
    – Shpoogen
    Commented Nov 12, 2018 at 17:54

In case you're always searching a set of the same places, the QGIS functionality "spatial bookmark" might help out. It's not a plugin to search places as GeoSearch, but I am now using it instead to quickly relocate to places I've once searched (and marked with a bookmark).

  • wow I didn't know about that, thanks!
    – Shpoogen
    Commented Dec 5, 2018 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.