1

When I've created Hillshade in ArcMap and received the output raster, I've noticed that output Hillshade has one pixel less than I have in the source DEM. It doesn't matter where I create it (ArcToolBox or arcpy). Aspect, Slope work fine without that artefacts.

enter image description here

I've tested this tool on ArcGIS Destop 10.4.1 and 10.6.1. May be somebody know how to solve this problem.

I've tried to do same in QGIS and discovered the option "Compute Edges" in Hillshade dialog (pic below) which solved the problem with edges. Is it possible to do same in ArcGIS (may be in script)? I need to processing a lot of rasters. enter image description here

  • 2
    Welcome to GIS SE. As a new user please take the Tour. This is the expected behaviour. The hillshade algorithm converts four neighbor cells into one, with corners at the previous centers. – Vince Oct 25 '18 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.