1

I'm trying to use the Vector > Analysis Tools > Sum Line Lengths in QGIS version 3.2.3-Bonn. I'm inputting a ploygon (Multi Polygon) and a Lines (MultiLineString) shape files. I'm hoping to get the count and length of lines in each square of the polygon grid. The error I'm getting is;

Algorithm 'Sum line lengths' starting… Input parameters: { 'COUNT_FIELD' : 'COUNT', 'LEN_FIELD' : 'LENGTH', 'LINES' : 'X:/SAERI Contracts/CFL/Toothfish ms/Map/layers/LL_lines.shp', 'OUTPUT' : 'memory:', 'POLYGONS' : 'MultiPolygon?crs=EPSG:4326&field=fid:double(20)&field=left:double(23,15)&field=top:double(23,15)&field=right:double(23,15)&field=bottom:double(23,15)&field=id:long(10)&uid={411cf258-ceb3-4878-810c-8c14545a6a79}' }

Traceback (most recent call last): File "C:/PROGRA~1/QGIS3~1.2/apps/qgis/./python/plugins\processing\algs\qgis\SumLines.py", line 119, in processAlgorithm QgsFeatureRequest().setSubsetOfAttributes([]).setDestinationCrs(poly_source.sourceCrs(), context.transformContext())), feedback) Exception: unknown

Execution failed after 0.02 seconds

Both layers are in the same projection (WGS84) and I've also tried UTM21S but get the same error.

Or is this a bug?

Or something wrong with my installation?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.