0

Possible Duplicate:
What is up with QGIS buffer tool units?

A similar question to this one has already been asked How to change the unit of measure from degrees to meters in QGIS?, but none of the steps suggested has worked for me.

I have a data set with over 37000 points. I would like buffer the points with 5km, 10km, and 15km radii using f-tools, dissolving the buffers to see how the total surface under the buffers evolves.

By default, my qGIS has the CRS set at WGS84 (settings-> project properties). My shape file with the points was also initially set at WGS84.

As I mentioned, I would like to draw the buffers with the radii set in metric units, however, the units are always in degrees.

I have tried adjusting my qGIS project settings both before and after opening the shape file, modifying the shape file settings (always changing both to EPSG:3414 - SVY21 / Singapore TM as this is data for Western Malaysia) directly, etc.

Somehow, I always get buffers in degrees rather than metric units.

marked as duplicate by underdark Jul 22 '12 at 16:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • " modifying the shape file settings " how are you doing this step? – Nathan W Jul 22 '12 at 13:04
  • By right-cliking on the layer in question, and then going either into "set layer CRS" and "set project CRS from layer", I have tried both. – Christian M. Jul 22 '12 at 13:36
  • 2
    Try doing Right Click -> Save As.. and re-save the layer with a different CRS. – Nathan W Jul 22 '12 at 13:44