3

I have little to no GIS experience. My workplace has no GIS capabilities.

I am using QGIS 3.0.2 (64 bit) on Windows and I created a new attribute for a vector layer (shapefile) through the field calculator by concatenating 5 other attributes. I first tried to do it with the attribute table open (which froze my machine), then tried it without opening the attribute table and it worked.

However, when I disable edit mode and save the attribute table, QGIS just keeps thinking and thinking. I left it running overnight but it was still going in the morning and I ended up shutting it down.

There are approximately 1.9 million entries in the attribute table to be saved and I understand it may take a while but should it take that long to save or am I missing something?

Or is there a better way for me to create a new attribute based on existing attributes so that I can join it to other layers in the future (join based on this new attribute)?

I am concatenating 1 string field, 4 integer fields & hyphens into a 14 character (max) string field (i.e. NW-15-25-15W5 or SE-24-112-10W4).

1

As @DanC commented, the problem may be the limitations of shapefiles. so it looks like you could benefit from another format.

You could convert your layer(s) form SHP to ("Save As") a GeoPackage. I think this would allow you to concatenate the data as needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.