0

I try to install QGis Server 3.4 on a new Windows Sever 2016 Machine and when I try the fcgi exe in a commandline window I get an error saying:

Couldn't load SIP module. Python support will be disabled.
Traceback (most recent call last): Line 1, in ModuleNotFoundError: No module named 'qgis'

My guess is that this is some kind of error in a environment variable but I am not totally sure.

The variables I have registered is:

  • PATH "C:\OSGeo4W64\bin;C:\OSGeo4W64\apps\qgis\bin;C:\OSGeo4W64\apps\Qt5\bin"
  • PYTHONHOME "C:\OSGeo4W64\apps\Python37;C:\OSGeo4W64\apps\Python37\Scripts;C:\OSGeo4W64\apps\Python37\Lib;C:\OSGeo4W64\apps\Python37\Lib\site-packages"
  • QGIS_PREFIX_PATH "C:\OSGeo4W64\apps\qgis"
  • QGIS_AUTH_DB_DIR_PATH "C:\OSGeo4W64\apps\qgis\resources"
  • QT_PLUGIN_PATH "C:\OSGeo4W64\apps\qgis\qtplugins;C:\OSGeo4W64\apps\Qt5\plugins"
  • GDAL_DATA "C:\OSGeo4W64\share\gdal"

Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.