After having installed Mac OS X 10.7 I can't install Quantum Gis as it maintains that I have not installe the GDAL Framework, which I have done (several times). Have anyone experienced the same problem (and solved it)?

  • It seemed that after having installed GDal 1.9 i could not install the older Qgis 1.7 - sorry for beeing a newbee :) – Lasse Jesper Pedersen Jul 23 '12 at 15:41
  • I can't remove the question, but i hope you will notice that I have worked it out before answering. – Lasse Jesper Pedersen Jul 23 '12 at 15:42
  • 4
    Answer the question yourself and mark it as accepted. Be sure to be verbose, so the answer could be helpful to others in the same predicament later. – lynxlynxlynx Jul 23 '12 at 15:47
  • I understand the instructions on posting which say do not ask a question but I don't have the required 50 reputation points on GISExchange to make a comment. I'm also struggling with installing QGIS on OS X Lion. I've installed GDAL 1.9 and GSL frameworks a couple of times via kyngchaos.com but I still get the "Failure. The GDAL 1.9 framework is required." Error when I run the QGIS installer. – Alastair Leith Aug 1 '13 at 1:54

I understand that you solved this for yourself but I had this problem as well and had a slightly different solution.

I had already installed GDAL 1.9 via Homebrew but was receiving the "QGIS requires GDAL framework" when trying to install QGIS. The issue turned out to be that I hadn't installed the GSL framework. Strange that it was complaining about no GDAL, but after installing KyngChaos' GSL framework, the QGIS install worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.