0

I am having problems to run GRASS7 from the processing tool. Always run the following error that is not corrected instaled. I ve reinstall QGIS several times, even tried different versions,as also tried many solutions present in similar questions in StackExchange as copy msys, etc.., but so far unsucessfully.

enter image description here

enter image description here

What could be the problem?

enter image description here

  • 1
    Looks like the GRASS7 folder C:/PROGRA~1 is suggesting a 32-bit installation folder (Program Files (x86))? Your QGIS might be 64-bit version. – Kazuhito Nov 3 '18 at 10:50
  • Hi, the QGIS it´s a 64 bit version. I am using Windows 10 Pro 64 bits. – Vitor Pina Silva Nov 3 '18 at 15:53
  • Then you may have another GRASS 7 under C:\Program Files\QGIS 2.18\apps\grass\grass-7.4.1. Could you set it up as your GRASS7 Folder and see what happens. – Kazuhito Nov 3 '18 at 16:01
1

This problem it´s solved. i realize that anti-virus had block grass and several components. So i have unblocked them, and have re-installed QGIS 2.12 first, then QGIS 2.18. Then copy msys as well as grass 6 folders in apps in QGIS 2.12 to apps in QGIS 2.18. And now both run perfect grass 6 in QGIS 2.12 and grass 7 in the QGIS 2.18

Many thanks for your time and help.

  • Please accept the answer to mark it solved. – markusN Nov 5 '18 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.