I've just installed the latest verion of QGIS (3.4.0) on a MacBook Pro 13" (3.3 GHz Core I7) MacOS 10.14. The application seemed to work fine at first. On a certain point I've tried to open a recent project via Project/Open menu and had a system freeze for 12 seconds. During that time the whole system was not at all responsive (just mouse moves did work). None of the other applications worked in any way, I couldn't even move other app's windows, the system monitor didn't show any significant increase of activity and instead of the expected functional filemanager-window a tiny little inactive shadow of the filemanager-window was displayed ... as you might guess in the image below.

I was able to reproduce this behavior for several times - even after restart of QGIS.

The whole thing might be related to QGIS 3.4.0 Madeira: unresponsive but it is on a mac and it doesn't seem to affect the "rest" of QGIS.

... has anybody any idea how to handle that problem ?

enter image description here


I had the same problem oppening or saving files on QGIS 3.4.3 and Mojave 10.14. The bug was reported here Bug report #20381 and looks to be related to MacOs acessibility stuff.

Thanks to Yaroslav Vasyunin a workaround was found. On your Mac, go to "System Preferences"-> "Security & Privacy" -> "Privacy" -> "Accessibility", and disable QGIS. It worked perfectly for me and will allow you to use it while a fix is on its way in next update.


thx to peter petrik and his post in github osgeo issues/qgis3 homebrew fails i have found a version that doesn't trigger a system freeze every time a file-related acitivity is started. packages provided by lutraconsulting here: qgis 3.4.2 packages work without that kind of lags.

that package uses python 3.7 (!) which might cause troubles - thus my next step will be to find out how to switch from 3.6.x to 3.7. without affecting anything that is doing it's job right now.


there is at least a working workaround: open qgis3 from terminal with the following command open /Applications/QGIS3.app/Contents/MacOS/QGIS

see bugreport


The first release of a new version always has bugs. Please make a bug report: https://issues.qgis.org.

Update: see the bug report for the status of this bug.

Older versions of QGIS are available here and here, but not all versions are available for Mac.

See this question for more info about getting old versions of QGIS for Mac.

Status report 2019_01_12: the problem is still existing in version 3.4.3 ... which is the 4th version of 4. for more information see here.

  • done - priority was changed to hig recently ! – robert tuw Nov 9 '18 at 7:49
  • Can you add the link for the bug report? That way anyone who comes along later and has the same issue can easily follow the link and find out the status of the bug fixing process. – csk Nov 9 '18 at 19:05
  • the link for the bug report: issues.qgis.org/issues/20381#change-95741 ... with a "workaround" for the moment ! – robert tuw Nov 12 '18 at 9:29
  • has anybody any idea where i can get mac 3.3 version ... recent 3.4.1 2018-11-11 version doesn't solve the problem and i can't wait. ??? – robert tuw Nov 14 '18 at 9:07
  • meanwhile version 3.4.2 ... bug report is online for a couple of weeks... nothing changed. does anybody know whether mac support is still active ? and where to get a version 3.3.x ?! – robert tuw Nov 26 '18 at 8:22

status at 2019 feb.: qgis issues report article at https://issues.qgis.org/issues/20381#change-95741 covers two different "solutions":

  1. start qgis from terminal with open /Applications/QGIS3.app/Contents/MacOS/QGIS or create a bash script (see bradypus' contribution bug report #48)

  2. open "System Preferences"-> "Security & Privacy" -> "Privacy" -> "Accessibility", and disable QGIS

... see the ongoing discussion on the bug report page!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.