1

I am trying to setup OpenLayers on my computer.

I am following the directions here: http://openlayers.org/en/latest/doc/tutorials/bundle.html

But when I do: npm install --save-dev parcel-bundler I get error:

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4
npm WARN ol@1.0.0 No description
npm WARN ol@1.0.0 No repository field.

How do I fix this?

I have tried searching for this on google and duckduckgo but to no avail.

I have found the first error described in more detail here:
https://www.npmjs.com/package/browserslist/v/1.5.1

Don't get how to solve it though.

  • it's more likely parcel-bundler's issue. – Chase Choi Nov 7 '18 at 0:57
2
+50

These are warnings, not errors. You can safely ignore them:

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

This tells you that if you are using browserslist v3 yourself, you could run into compatibility errors.

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4

This can be safely ignored, as there is a fallback for fsevents on linux implemented.

npm WARN ol@1.0.0 No description
npm WARN ol@1.0.0 No repository field.

You can add content to the description field of your package.json file, but don't have to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.